Somehow Lost Republic Service

What phone do you have?
Moto E4
What plan are you on?
My Choice + 2 GB
Does your plan include data, or just talk & text?
Yes


Issue Description

Phone was fine at work today. Slipped it in my purse while screen was active. When I got it back out, the screen looked a little strange, but I swept my finger through it and tried to go on. Now it’s saying I have no cellular networks, can’t call or text out even while on wifi, and need to re-register with Republic. I tried resetting network settings and didn’t work.

Try this:

Please go to Settings – About Phone – Software (or System) Update while connected to wifi. You should find an update waiting. Once it has applied and the phone has restarted, please go back and check again for another update. Once all updates are applied you should find that the phone is working properly again.

3 Likes

I am so grateful, it looks like I’m back in business again, although it looks like I got re-activated? Anyway, thank you so much!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer