Sound problems on calls


I’ve noticed a definite difference in sound between wi-fi and cell calls since first moving from 2.0 to 3.0. Voice quality and volume sound great on GSM cell, but thin and at a reduced level on wi-fi. It’s much more noticeable on RW to RW wi-fi. The volume setting necessary to hear a friend who signed on with RW recently resulted in an uncomfortably loud level today when I later talked with a family member who’s on landline. Making matters worse, my Moto X Pure occasionally gets handed over to cell even when I’m sitting no more than 6 feet away from my TP-Link Archer C7 router set for max wi-fi signal levels. The sound difference is jarring.

Am I the only one experiencing this? I have no idea whether the fault is basically with my phone or the RW system. But there’s a problem somewhere. I’m pretty sure it’s not the router since the same things happened with another router.


Have you tried power cycling the modem or gateway. There is a document created by an ambassador @jben. This usually helps get setting correct.
WiFi 1st - Maximize your WiFi/Router - Community Guide


The fact that your phone is handing over to Cell when near your WiFi is a very good indicator that the Router signal is in problem. RW will monitor the signal and attempt to provide a usable call by combining Cell with the WiFi … but poor WiFi combined with a weak cell can be troublesome.
I would look at the 1st two numbered steps in the Quick Start section of the reference that @bocephous provided

1 Like

Thanks for the suggestion. I regularly do a total system boot at least once or twice a month, the last one today. All related F/Ws and drivers are up to date. Visualware BCS gives my VOIP connection a clean bill of health.


What’s the packet loss, somehow the wifi isn’t as great as you might think.
Run this speed test and report the numbers back.
Sourceforge speed test


My router wi-fi signal is good as was the signal of the router I used previously. Problems were exactly the same with that (D-Link DIR-859). And my GSM signal is excellent everywhere in my house, often all bars. I wouldn’t have problems with calls if I just turned wi-fi off and used cell all the time. Also, I’ve done everything Bocephus suggests, total system reboots countless times.


Latency/Ping: 44ms
Download Speed: 69.5 Mbps
Upload Speed: 13.9 Mbps
Packet Loss: 0%


My results are
Latency/Ping: 14ms
Download Speed: 57.4 Mbps
Upload Speed: 41.2 Mbps
Packet Loss: 0%
See any differences?
Your latency is high so the voip has a huge lag to it.


I see, but I’m wondering how reliable that test is. My upload speed is supposed to be 5Mbps, but does usually run around 6. I never got anything even remotely close to 13.9 before. Latency varies according to the site and even the time of day. I just ran this one on another tester. Results


I got my same results approx.
Lat/Ping: 21
D/L: 52.25
U/L: 5.64
I knew my U/L speed was too high but in this test I tested 4 times with my D/L nosediving to as low as 28.21
52.25 to 28.21 is a huge spread when the only thing on my internet is a phone and the testing laptop.


FYI it’s fine per jben’s Ts&Ts. Mine is higher and have never seen the quality or handover issues so would doubt that’s the cause.


That is a big D/L spread. Maybe there are still a few bugs in that test program. I did find a Speedtest.Net app for Android in Google Play, so installed it on my Pure. It shows speeds in the usual 70 down/6 up Mbps range and latency averaging about 24ms.


I think I can safely rule out my wi-fi as the problem. I made calls today with my old Moto E2 on Google Voice. Audio on my end was better than anything I’ve heard in a wi-fi call using my Moto X Pure on RW. Of course, I couldn’t make a direct cell/wi-fi comparison, but volume was good and sound had good fidelity unlike the thin sound from my Pure on wi-fi. I’m afraid it’s likely a phone problem.


The easy way to make a cell vs WiFi comparison is to make a call to a willing ‘test subject’ and switch back and forth from WiFi to Cell.
To set up for this test go into the RW App/Settings/Advanced settings/Manage handover and :solved: the box. Now during the call you can swipe down from the top and the ‘Handover’ notification will be displayed and you can Handover to Cell
You will need to disable ''Handover to WiFi when appropriate" (uncheck) and control the Handover to WiFi as you did to Cell

1 Like

I have made cell/wi-fi comparisons on my Pure. Audio I hear on GSM cell is at a good volume with very good fidelity. Audio I hear on wi-fi is at a noticeably decreased volume with much-reduced fidelity. The sound isn’t unlike that of an old landline telephone years ago. I never had that problem with my Moto E2 when I was on RW 2.0. And, as I indicated above, the E2 still sounds good on wi-fi via Google Voice.


Ok, now I would check the two most common problems with WiFi … these are documented in steps 1 & 2 of the Quick Start section of WiFi 1st - Maximize your WiFi/Router - Community Guide and then retest and post results


Thanks, jben. Did these things. No difference. I let the phone decide which wi-fi band it wants and it prefers 5GHz. Currently on channel 149. WiFi Analyzer doesn’t show any other signals on that channel. Getting -31 dBm. I’ve tried 2.4GHz, but things are no better there and there’s a greater chance of interference. SpeedTest.Net on the phone just showed 30ms latency, 70.51 Mbps down and 6.18 Mbps up (my ISP claims 60/5, but extra “padding” puts speeds more in the 70/6 area). Do you by any chance know where the RW system server is located? Is it in Raleigh? I should check the location RW Internet signals are coming from to determine realistic latency as that often varies with traffic and distance.


Based on what you’re seeing and the use of 5GHz band I think that your WiFi is probably ok, you may want to open a Ticket and make sure that you include the process you used to determine the diff between Cell & WiFi. That and if you do a test call that provides a clear difference I would give them the time and numbers the call was to/from. If done shortly after the Test call is made, this will possibly give them enough info to analyze the problem for you.

1 Like

Thanks. I’ll do that after making some test calls over the weekend. I have noticed one thing that could indicate a problem, although probably not. I usually shut my phone down at night. Never paid much attention to the screen in this process, but recently noticed the RW “Buy SIM” page is appearing. It’s dimmed, but still fully readable. That seems a strange thing to appear during shutdown.


No, it is not odd. At some point in the process of shutting down the phone, the SIM process turns off that causes the message. The SIM and our App work together but are separate processes, so if one shuts down first then there could be oddities. This can happen on startup and shutdown.

Message an
Expert customer