Spectrum-Charter using Sagemcom F@ST 5260 router prevents users from making WiFi calls

• Description of the problem, include any visual indicators on your phone
Can’t make or receive wifi calls on home wifi since switching ISP to Spectrum (formerly Charter). Phone just says “calling on wifi….” and never connects. This is with 2 phones, a Moto X 1st gen and a 2nd gen (RW 2.0).
Wifi still works for web, data, texts, anything else.
Can still make calls on other wifi locations.

• Name of ISP (Internet Service Provider)
Spectrum (formerly Charter)

• Type of service, i.e. DSL, cable, satellite, broadcast
Cable

• Router brand, model, and version (all the numbers and letters from the model designation on the nameplate)
Sagemcom F@ST 5260

• Firmware revision of your router if you are able to find it.
Hardware Version 1.0
Software Version SG9C120074

Other troubleshooting:
I’ve been trying to work through the “Maximize your wifi community guide”, but I cannot figure out how to do this suggestion:
"Disable SIP ALG (Application Level Gateway) … Check router’s configuration to ensure it does not have SIP or NAT ALG enabled"
I cannot find anything about this in my router settings. I can find a section called Firewall, in Access Control, where it appears I can create some sort of custom rules, and I can find SIP in a dropdown list. But I don’t know what to do from there (Protocol? Port? Action = “reject from both way”?). I don’t know anything about these; to choose a custom rule, I would seem to be switching from “Level = Low” to “Level = custom”, and there’s already a list of 15 or so rules in “custom”.

Any help would be appreciated. We’ve been with RW for 4 years. Our phones are old, and now we can’t make calls from home without turning off wifi. I tried a tech support ticket, but they sent me here.

I too am on Spectrum and recently like the past 48 hours or so… My phone takes about 10-15 seconds to make an outgoing call on wifi and takes about 5 seconds to hang up the call when I press the end button. I am however able to make wifi calls. Sometimes my phone uses cellular but most of the time it is wifi. The wifi taking a while to connect has happened before and usually clears up and starts working normally in a couple of days. Hope that this helps. Probably something on spectrum’s end but who knows.

Unfortunately, from all the doc I have found the Advanced functions are not documented. As this is a ISP specific router they sometimes mask off the good stuff. :frowning: In the past many have had to resort to working through the ISP support structure and have them make the necessary changes
Course of action I would recommend:

  • Check to see if the current config is not blocking any of the necessary ports … this can be done by running the three routines shown in the Open Access - Required Ports & Protocol section of Router Tweaks - Keep WiFi 1st - a Community Guide … this should result in something like
    You have reached this page on port 5090. Your network allows you to use this port. (Assuming that your network is not doing advanced traffic filtering.)
  • Then assuming all 3 are positive, I would contact the ISP and have them check their configuration to ensure that SIP or NAT ALG are not enabled
3 Likes

I seem to have access to a number of advanced settings, I just can’t find SIP / NAT ALG. Any chance it could be this:

I’ve been on Spectrum/Charter for a couple of years. They supplied a modem, Arris TM822A, at no cost and for the router I use an Asus 1300.. All works great with no tweaking.

1 Like

As I can’t find any reference material, I would even hazard a guess.
SIP ALG (Application Layer Gateway) normally messes up VoIP registration, preventing the filled in ARC on RW, causes 1 way or no way audio as well as inability to initiate or receive.
Normally the community can help … but I would strongly advise you work with your ISP, perhaps the solution that @fords.jmk6yx suggested above will work for you?

2 Likes

I don’t think he suggested a solution. I don’t think my ISP will give me all new equipment on the random chance it will work. The local group probably only gives out whatever they consider the current equipment.

I just got off chat with my ISP. They claim that the router has SIP / NAT ALG automatically disabled (it’s not even possible to turn on). So now I don’t know what to try.

You might try running an Internet Speed Test to determine if something with your connection makes it unsuitable for Wi-Fi calling. A test I like is at https://sourceforge.net/speedtest/. You can even run it from your phone if you like (but if you do it on Chrome, be sure to turn off the data saver) At the end of the test there is a “View Details” button that gives you a number of displays, including the “In Conclusion” table at the bottom that looks like this:

mos

The results can tell you what your connection is suitable for, and where the problem is occuring.

3 Likes

Sharing the results (solutions) of user problems solutions is important to many of us, to that end, a few of the users have created ’Republic Wireless Wiki’ … one of the many things is provides is a section titled ’Republic Wireless and your Wi-Fi Router’
If your ISP provides a different router solution it would be helpful if you could add both the good and the bad router to this site, and possibly save a few folks grief in the future
Thanks and best of luck
Ben

I just ran the above internet tests from my phone on my home WiFi, and everything passed each time. Oh well, guess we’ll give it a couple of weeks, but our phones are old, so we’ll probably have to try a new service with new phones. I tried a new Moto g4 early in the year, but it chewed through a normal months worth of data in 5 days, so I sent it back. That was going to be double the price.

So, silly question here, but have you tried VoIPing the phone?

Open the dialer, then dial ##8647## (On Samsung only, touch the call button)

The dialer will clear, and the white arc notification icon will reappear after about a minute. (If the white arc notification icon does not reappear, restart your phone. The white arc should then appear after your phone restarts.

Video demonstration at https://www.youtube.com/watch?v=yB_MV7ajSyE

Tried that, didn’t help. The problem is only on my home wifi, not other wifi, so I was hoping there might be some general router settings help somewhere. But aside from the SIP thing, I’ve haven’t ever found any general suggestions.

This is the best practice information on router settings

That’s what I’ve been working through this whole time. There’s really very few settings there, and I’ve done everything there.

So, how can I turn off wifi calling from home, without having to turn the wifi entirely off and then remember to turn it back on every time.

Also, should I have any reason to believe that a new phone on the new plans from RW would be any better? As I understand it, other Android phones default to using cell for calls, but can automatically connect to my wifi for data, which would solve my problem. Do the new RW phones do that? Or would they still work the same as my 2.0 phone? (only trying wifi calling unless I turn wifi off).

The best way to prevent a WiFi call on a network is block the following ports in your router

5090 UDP which is used for call set up
6000-29999 UDP which is used for voice/audio

As a wifi first cell backup provider Republic activated phones will try to call on WiFi first be it a legacy phone like yours or a 3.0 phone [this is done via the republic app]

2 Likes

Sagemcom F@ST 5260 User Manual that I was able to find does not expose any of the additional functions.

  • I assume that you utilized the 3 links that were provided in the first bullet of my comment above … did they all work with positive feedback?
  • The only other thought is to try limiting your phone to 2.4 and then to 5.0 in case they are having problems with the Auto setting in WiFi
  • A couple of years ago, I fought AT&T for problems. Wireshark traces ensured that all the necessary data was being passed to the router, however I could not connect. They dispatched techs that found problems with the line, the hub etc but problem persisted. Ultimately I challenged the last tech to replace the router (just to humor me) … he did and it worked fine after that
    • I would probably go to my local big box, buy a router and try it … if it worked I would quit paying them the monthly usage fee and be done with it … else return it to the big box, no harm no foul
2 Likes

I am also having problems calling out on WiFi, Moto G3 and Moto X 2nd Gen phones. This started around December 9, 2017 for me. Prior to that everything was fine. I also have Charter/Spectrum with the Sagemcom Fast 5260 router. My phone works fine elsewhere calling out. Laptop working great, I have excellent WiFi signal. All the things that are recommended to check out have checked out fine with me too. I have temporarily “fixed” my calling out problem by utilizing the “Handover” option under The Republic App, Advanced Settings to “allow manual handover” from a WiFi call to Cell. I’ll dial the number, then swipe down when you get a wishbone type image on the top and hit the button to switch to cell. At least you can call out from home while this gets resolved. I am not having any luck either so very interested in this thread!!! I also will add, however, than when I did the port tests, port 443 is reached on port 80 (which is also what other RW users are finding). BUT, frequently I am also getting a “error invalid HTTP response”. So my port 443 test goes back and forth between these 2 responses. Plus, I just swapped out my Sagemcom router (for another Sagemcom 5260) and it did NOT solve my issue. I am going to try the ASUS 1300 router and/or ask Spectrum to give me another brand router and see what happens. It is strange that the Sagemcom router was working fine for me until around December 9th…

It’s just called the ASUS 1300?

I am having the exact same issue with a Moto G 1st Gen with spectrum internet. My issue also started within the last week or so. Very frustrating.

Here’s the link: https://smile.amazon.com/RT-ACRH13-Dual-Band-AC1300-4-port-Gigabit/dp/B01LXL1AR8/ref=sr_1_4?ie=UTF8&qid=1512997421&sr=8-4&keywords=asus+routerhttps://smile.amazon.com/RT-ACRH13-Dual-Band-AC1300-4-port-Gigabit/dp/B01LXL1AR8/ref=sr_1_4?ie=UTF8&qid=1512997421&sr=8-4&keywords=asus+router

Message an
Expert customer