Sporadic Google Maps navigation failures

What phone do you have?
Moto E 2nd gen, "HW version P30"
What plan are you on? 1 Gb “refund” plan
Does your plan include data, or just talk & text?
Data


Issue Description

PROBLEM: A few weeks ago, Google Maps navigation function stopped working consistently. The phone appears to have a concept of where I am (inexact, jumps around) but does not navigate. No ‘turn-by-turn’ navigation directions. However, it is not consistent. On my drive to work, eventually the navigation will start, after 20-30 miles. Also, sometimes it works fine from the start.
Browsed forums, uninstalled/reinstalled Google Maps updates, cleared cache. I have a Geotracker application that is also sporadically not working properly. I installed “GPS Toolbox”, although I’m not sure exactly how to use it.
Generally, I work in technology, and so have technical skill, but don’t like to ____ around with it on my personal time. The evidence is telling me it MAY be hardware related (more than 1 app failing) but I also am considering it may be location related. I don’t have enough evidence to prove that, however.
Thoughts welcome.

Hi @edl.atob8v

Please open the Settings app, select Location and ensure Mode is set to High accuracy

if the problem persists, try booting the phone into Safe Mode. Here’s a link to the instructions for that:

Safe Mode – Republic Help

If the Google Maps works well in Safe Mode, this is being caused by an ill–behaved app.

2 Likes

You’re quick… :slight_smile:
Yes, it’s set to ‘high accuracy’. I’ve been through most of the basics from Google Maps & other forums.

I will try the Safe Mode and see what happens. Thanks.

2 Likes

I did safe mode. Still the same problem. I tested it with “GPS Status & Toolbox”, which also has location trouble at the same time Google Maps does. I did the same navigation to the same location with another Android phone, which worked fine, at the same time mine had problems. So, I suspect I have a hardware problem with the GPS function of the phone. Any other input or advice is welcome. I’m suspecting I need to replace it, but I am not sure of the applicable policy. Thanks.

I don’t have a E 2nd Gen to test, but I would suggest you check the :motohelp: Moto Help App that can be found on :appsicon: … if it’s at the latest level then you should have a ‘Fix’ tab that provides Hardware Test, including the GPS.
Then you should consider a factory reset, which may bring it back to life

1 Like

If all else fails there really isn’t a policy for a hardware issue considering the phone’s age. You can choose to upgrade to a more modern phone which I would highly recommend for a much better overall user experience. Other options would be to have the E2 repaired or purchase a used Legacy RW phone. Republic Wireless Phones – Republic Help

If you choose to upgrade to a compatible 3.0 RW phone you would need to upgrade to the My Choice plan. Affordable, No-Contract Cell Phone Plans | Republic Wireless

:flight_departure:

1 Like

Still haven’t motivated myself to do a factory reset. I have a feeling that that will cause me to have to restore a bunch of stuff. Problem is sporadic and hasn’t returned for a day or so.

Know the feeling, the last thing i want to do is go back and personalize my app settings.

Sporadic GM nav issues may be cause by variations in your cell signals. Sometimes just temporary due to tower maintenance or environmental changes. Sounds like your E2 may have a future.

:flight_departure:

OK, folks, I don’t want to be the one who screams for help and then disappears as soon as I get it.

I did the factory reset on the phone last night. I THINK I moved everything I wanted to save to my SD card, and backed up everything I need to get 98% of what I had back. I haven’t had a chance to check yet. I was impressed that Google’s backup/restore feature APPEARS to have restored quite a bit of my original “environment” back. I have to go through everything and verify/restore as needed.

I used the navigation feature on the way to work this morning, and it worked fine. However, the problem has been sporadic, and it will probably take a few days of consistency to convince me that it’s fixed.

Stay tuned and thank you for the assistance.

3 Likes

Thanks for taking the time to report back. Please do keep us posted.

Just a side note, in reply to “jben”. I looked for the “Moto” application. I do have one, but there’s no “Fix” function that I can find. Just a lot of things that request access to store information about me. :slightly_smiling_face: (What else is new?) Maybe I don’t have the right version. With all the things I have to upgrade, I’m not feeling like upgrading my Moto app unless I really have to. But thanks.

I understand your hesitancy and not wanting to fix what you you don’t see as broken. However in the software world, there will always be incremental fixes as well as features and functions. If designers/manufactures waited for the code to be 100% perfect it would never ship in the first place. Republic and other companies spend a lot of time and effort doing testing, but it is impossible to emulate all of the real world problems that the code must face.

1 Like

OK, sorry. At the risk of sounding like an ignorant user :slight_smile: … I guess after doing the factory reset, I will have enough stuff to re-import and set up… I’d guess if my “Moto” app were outdated, either the app itself or Google Play services would figure out that it needed to get upgraded, and take care of that, since it seems to work that way with most things. So, I wasn’t going to go hunting for an upgrade to Moto. After feeling guilty and looking it up, it doesn’t appear the Play store has a higher version of it. It’s at 3.0.something, which matches the version in the store. Thanks anyway, though. Perhaps the more functional version is only available on higher-end phones?

  1. You don’t sound like an ignorant user :smile:
    • One time during my 30 yr career at IBM, I was part of a 10 man team that spent a week of 10-12 hr days in a major customer account that our support team had not been providing the required ongoing maintenance to standards. A very young and unknown (to most of us) IBM Mgr was on site during the period and on the final day we were all gathered into the board room for the final update to their Exec’s including the CEO.
    • It went like this
      • Good afternoon, I am xxx and we are pleased to provide you the results of our team’s efforts this week …
        "It was a user problem"
      • Some very shocked faces were met with a long and painful pause, and then a very firm declaration
        "If you hadn’t tried to use it, you wouldn’t have had a problem"

This forever changed my definition and understanding of ‘User Problem’

PS: I just checked my Moto E1 the Moto Help is at 3.2.0 and has the Fix Tab an functions

1 Like

Sounds interesting… I will have to use that some time. :slight_smile:
So, I guess my current phone model only supports version 3.0?
If there’s an upgrade, I’m happy to try it, but am not sure where to find it.
Thanks.

@edl.atob8v,

In his earlier reply @jben jben was referring to the Moto Device Help app. Should be in the app drawer. https://play.google.com/store/apps/details?id=com.motorola.genie&hl=en

:flight_departure:

2 Likes

The conclusion I came to was that there is a different version of Moto Help that isn’t compatible with my phone.

Reset complete, applications and most things all working. HOWEVER, the problem persists. My GPS failed this morning, in the same way it did prior to the reset. So, I guess it is time to replace the hardware. That will be my course of action, in case anyone has any more ideas.

Thank you for the input.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer