Sporadic problems making and receiving calls on cell data and data roaming

What phone do you have?
I have a Moto G (3rd gen)

What plan are you on?
I’m on the Republic Refund plan
Does your plan include data, or just talk & text?
The plan includes data, but I don’t use much of it


Issue Description

Most of the time, I can make and receive calls well. However, sometimes people have to call me several times before I get the call, and when it won’t go through it says to them, “The Republic Wireless member is not available” (I think this only happens when I’m on cell data, not WiFi). For the first few tries they make, it won’t make my phone ring, but I’ll get a missed call notification a few minutes later. If they text me to call them, I can usually reach them on the first try. Similarly, when I try to make calls it sometimes will not ring and then a minute or so later my phone will end the call on its own, so I have to try a few times before it actually rings the number I’m calling.

This occurs even when my phone shows that I have a decent amount of service, and it has been happening for at least several months. Yesterday, it was very bad, and it took way more tries than usual to get through, and the people trying to call me had to try many times to reach me. I was in roaming for some of the time yesterday, and it listed calls, SMS, and no data.

A potentially related problem is that several times a day my phone has started giving me a notification that is titled “data roaming” and says, “You’ve lost data connectivity because you left your home network with data roaming turned off.” What’s odd is that it even gives it to me when the phone shows I’m on WiFi or cell, in addition to the times when it shows that I’m on roaming data. I have my cell data turned on (but I only enable data on call and message-related apps most of the time) and have roaming data turned on in the Republic app, but my phone settings have the “data roaming” option greyed out so I can’t turn it on, and my mobile network settings has the “network mode” greyed out and stuck on “home only.” Is this perhaps part of the problem? How could I change this?

This morning I went into the system update section of my phone and updated PRL and updated profile. I also dialed ##8647## to reset my Republic credentials. I haven’t wiped the cellular settings yet, because that seems drastic, but I’m willing to try it if it could help. I haven’t had problems again today like yesterday, but I’m also not in roaming area today either. I’ve been trying the troubleshooting parts of this page: Make and Receive a Phone Call – Republic Help

I live in an area with at least fair data and cell coverage, with some roaming usage (I checked the Republic coverage map for my area. My phone is three years old and functioning well in all other respects. I really need to have reliable ability to make and receive calls, so I’m wondering if I can make any more changes? It seems odd that it’s a sporadic problem. Other people in my area use Republic and don’t have the data roaming problems that I do, and very rarely have to try several times to reach people, so it seems like its a problem on my phone and not the network in my area. Thoughts?

Hi @marthah.rvysop,

I’m sorry to see no one has replied yet. Let’s see if we can get some clarity on a few things.

First, you wrote:

This is the working for the default voicemail greeting. Do they leave you voicemail? (Have you checked for voicemail?) You can change the voicemail greeting in the Republic Wireless app.

The next thing I’m wondering about is where you mentioned:

If you’re getting a missed call notification, then that signifies that the call actually reached your phone, but didn’t ring. Have you checked all your settings to make sure “Do not disturb” is not turned on?
If what you’re getting is actually a voicemail notification, then the calls are indeed failing to reach your phone. This would indicate that for some reason, your phone did not have cellular service.

It’s possible that not having data can make it harder for our calls to go through. They take longer to set up without data and could cause the timeouts like you’re describing.

Where do you have this cell data restricted? In the RW app, or somewhere else?

This is normal and correct. Our service includes roaming where it is available, so there’s no need to try to adjust this setting.

Roaming agreements are made between our carrier partners and the other cellular carriers. We have no say in the roaming agreements. When those agreements change there is nothing we can do to force roaming to work.

Would you mind sharing the Zip code of the area where you are having this trouble?

Thanks for your response!

Yes, sometimes people do leave me a voicemail, and that works fine. I usually get a missed call notification as well as a voicemail notification. The problem is that the phone does not even ring for me, it just goes straight to voicemail.

When I restrict data on apps like Gmail that I only use on WiFi, I restrict it on the data settings in the RW app.

I have problems in the 60518 and 61364 area codes a lot, but it seems to be a problem pretty much everywhere I go.

From what you’re saying about roaming agreements, does that mean that it is possible that the problems being on roaming are the result of those agreements not letting me through right away and not because my phone is glitching?

Hi @marthah.rvysop,

I’m sorry to have taken so long to get back to you!

If you’re getting a missed call notification as well as the voicemail notification, that means the call is reaching the phone but you’re not aware of it.

The Zip codes you listed seem to have very good coverage, and since the calls are reaching the phone, I don’t think coverage is an issue, or even roaming.

Here are some things to think through and try.

  1. Clear the cache. How to Clear the Cache of All Installed Apps on Motorola, Google, Nexus, and Alcatel Phones – Republic Help
    This won’t delete any of your personal content.

  2. If you open the Settings app, then tap Sound and Notifications and then Interruptions, what does it say at the top of that menu? When calls and notifications arrive… what?

  3. Again in the Settings app, Sound and Notifications, tap Phone ringtone. Is Try tapping a few of the options. Can you hear the sample sound?

  4. In Settings, Sound and Notifications, tap App notifications. Scroll down and tap Phone. “Block” needs to be disabled (Gray and to the left.)

  5. If you open the Moto app and tap the Settings gear at top right, is “Assist” and option? If so do you have settings enabled for “Sleeping?”

1 Like

Hi @marthah.rvysop,

Were you able to resolve these sporadic issues with calls? Did you want to keep troubleshooting in our Community?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer