Staying on the internet

How can I get my Moto X4 to stay connected to the internet when available and not being used? If I have my phone sitting for a while, it will go back to cell, and I actually have missed calls. it goes to internet when I pick it up again. I am in a poor cell signal area. Thanks

Hello @kennethg.oerx02,

Welcome to the Community!

Try this trick… (I do this at home where I have good Wifi but a bad cell signal) :wink:

Turn on airplane mode (This will turn off cell and WiFi on your phone).
Then turn WiFi back on (leaving airplane mode on).

That should help, but let the Community know if you still have issues.

(Don’t forget to turn airplane back off when you’re ready to go out to a better cell signal) :wink:

1 Like

Looks great so far! Thank you!

3 Likes

Well, I thought it was OK. Text and internet work fine, but I can’t receive phone calls. Had a friend call and it said I was not available,
and went to voicemail, which I got.

  • This sounds like the unfortunate result of Googles ‘Doze’, which put the phones WiFi to sleep (both Transmit & Receive) to conserve battery.

Would you mind sharing your zip code? I would like to check cell coverage in your area. The most solid fix I know of (short of getting yourself an Extend Home kit for home use), is to make sure you have the best cellular service Republic Wireless has to offer. Republic Wireless uses one of two cellular carriers (GSM - T-Mobile or CDMA - Sprint). Perhaps one of them has better coverage than the other in your area. You can check which carrier you are using by looking at the following help article (sharing this information could help us, also).

2 Likes

I want to pass along a success story.

I am in a dead zone…no cell coverage in my neighborhood. At home, I turn on airplane mode, enable WiFi, and use my phone exclusively on WiFi. I also use @jben’s Doze Fix.

No issues at all with calls, texts, internet.

Also, a very weak cell signal eats away at your battery. Best to just give in and go WiFi!

My zip is 49727. Thanks

Thanks, I’ll try it.

It appears to me that you are in an area that would be best covered by CDMA. You can check whether your phone is active on GSM or CDMA by following the instructions at:


If the phone is active on GSM and you would like to try CDMA coverage, you can request a CDMA SIM card by following the instructions at:
1 Like

Thank you! My phone IS on GSM. I requested a new SIM card. We’ll see what happens. Thanks again, Ken

2 Likes

Another question if I may, is this problem common to all Android phones or unique to a few. I actually am considering a new phone for other reasons. Thanks again, Ken

Doze and App Standby are common to all phones using Android 6.0 and up.

1 Like

Thanks again!

2 Likes
Message an
Expert customer