Stop notification when switching between WiFi and cell

What phone do you have? MOTO E5

What plan are you on? Monthly

Does your plan include data, or just talk & text? all


Issue Description

Where I live, there is very spotty cell reception (concrete walls). So my phone is designed to be on Wifi for calls and data when there is no cell reception. It works just fine, but the phone has started to sound a notification alert each time it switches back and forth between cell and WiFi. Very annoying. How can I turn off the notification? Thanks.

I’m unaware of an audio notification to indicate a switch between cellular and Wi-Fi coverage. When the notification occurs could you swipe down from the notification shade and determine which app may be responsible for the notification?

1 Like
  • After a bit of digging, I have been able to ‘sort of’ recreate the problem you are seeing, and the rest of us were not hearing.
    • It looks like Android Notifications provides more granularity than I was aware of.
      • By accessing Setting / Apps & Notifications / Republic Wireless / Notifications / Republic Service Connections / Behavior; I was provided an opportunity to adjust if/how the Notifications were handled.
    • By Setting this to Make Sound I was able to replicate this behavior on a Samsung. Then activated my Moto X4 (Android 9.0) and tested/replicated it.
  • You should be able to adjust and turn the sound off … please let us know as this is how we can learn and pass on the information you help uncover.

Assuming you have good WiFi, you shouldn’t be switching over to Cellular, perhaps we need to look at your WiFi to ensure it’s as good as you are paying for?

Thank you for your response. However, “Republic Service Connections” was already toggled to “No sound,” as were all the other choices.

I found your last comment interesting as well, since my experience has been that the cell connection takes priority over Wifi, so that when a cell connection is available, the phone automatically switches to cell, and then back to Wifi when the cell signal is lost. Since a good cell signal is not usually available inside my condo, the phone normally stays on Wifi. But when it switches to cell and then back to Wifi it makes the alert sound.

For as long as I can remember, Republic Wireless has been ‘WiFi First’ so I can’t comment on your understanding, that “cell connection takes priority over Wifi”

  • You may want to change your settings in the Republic Wireless App so that you do not have ‘Enable handover on Networks’ selected for your home WiFi. It is available in RW App / Settings / Advanced Settings / Enable handover on networks
    Note: WiFi’s that you have authenticated to will automatically be selected by the App, and you can deselect as desired

Here is the Help Article on the How-to-Disable-Handover-to-Prevent-a-Call-from-Switching-from-WiFi-to-Cellular

Thanks for your help. However, in my RW app, under settings/advanced settings, all I have is "allow modify system settings: with a yes/no toggle.

I am at a loss, the 2 phones I have and the RW Help Article that I referenced all say the same.
Hopefully someone with a Moto E5 can chime in and help us out?

See if this helps. You need to find the republic wireless app in the apps drawer and tap on it, then follow the link @jben gave you by tapping on the gear at top right.

1 Like

There is no gear at top right.

So your republic wireless app when opened doesn’t look anything like this?

Yes, my app looks like that WHEN I access it directly from the app tray. However, using jben’s instructions and accessing it by going to settings first ( Setting / Apps & Notifications / Republic Wireless / Notifications / Republic Service Connections /) I get a completely different screen. I have now disabled Enable Handover on Network for everything but my home WiFi. If I don’t connect to that, I have no service at all. Let’s see what happens in the next few days. Thank you.

In the RW app, under Advanced Settings, there is an option that says "Handover to WiFi when appropriate, I would read that to mean that the cell connection is the default and the WiFi the backup. Not true?

You appear to have merged the two sets of instructions

  • 1st was an attempt to track down the Notification ‘sound’ you were getting
  • The 2nd set of instructions provided is how to prevent your phone from handing over to cell when you are on a specific WiFi

Hi @stephend.we6wpw,

No. WiFi is primary. However, if your call has moved to cell because the WiFi network is not able to sustain our standards for call quality, this setting would allow the call to move back to WiFi if the network improves. It also allows you to move to WiFi when you come home with a call in-progress and move into your WiFi network after being physically away from it.

I think we need to go back to the suggestion @cbwahlstrom made, as it doesn’t appear you saw it. When you get this notification, is there an on-screen notification you can long-press (tap and hold) to reveal a settings icon to tap to see what app is presenting the notification?

1 Like

Since we started this conversation, my phone has stayed on WiFi and I have not had a notification of moving to the cell network. I am waiting on that to happen so I can look to see what app is notifying me,

Now, about which is default, I literally have no cell connection inside my condo except very occasionally. My Wifi is extremely stable and fast. If WiFi is default, why would my phone ever try to switch to cell? When we started this conversation, it was because it was a night when the cell connection kept popping in and out and the phone would switch from WiFi to cell and send an audio alert, and then another alert when it went back to WiFi. I just don’t understand why the phone would go to cell the minute a signal is available if WiFi was the default.

Since we started this conversation, there has been no cell signal at all to trigger a move from WiFi to cell, and no notifications. I’ll let you know when it happens. Right now things are quiet.

Thanks for your help.

The presence of a cell signal does not trigger the phone to move from WiFi to cell, unless you have somehow configured your phone to do that.

If it did, most of our users would never be on WiFi, ever, because most have a cell signal available even in their homes. This would quickly get very expensive as they’d be consuming cellular data instead of using WiFi.

Our calling technology constantly evaluates the WiFi network and will move a call to cell if it notices signs of quality degradation. This is, by design, something that takes place before you notice the call quality going bad, and is more often based on your outbound audio, (what your caller, not you, hears) because most WiFi networks have slower, less robust upload speeds and badnwidth than download speeds and bandwidth.

Many things, such as a nearby appliance or neighbor’s WiFi network can interfere with your network, even when you have the very best ISP and router.

Okay. I give.

Hi @stephend.we6wpw,

I’m not quite sure what your reply means in the context of this conversation. Our Community is trying to help you find the source of an annoying notification and determine why your phone is switching between networks. Do you want to continue?

I’ve found a setting before, on a Samsung phone, that does exactly what you’re describing. I’ve never been able to find it on a Moto. That doesn’t mean it’s not there, just that I’m not able to point you right to it. I’m hoping the notification you see will give us all some insight.

Have you ever looked at your network environment with WiFi Analyzer, as described in this Tips and Tricks Topic?

When I’m researching notifications on my Moto, I take a look in the notification history log. Good info in there. You can directly access it in A11. It’s accessible in A10; I recall that it’s a widget. YMMV.

Thank you. However, I’m a 75-year-old with my first smart phone, and I have no idea how to access the notification history log.

Message an
Expert customer