Stubborn backlight on Moto Z Play

**What phone do you have? - Moto Z Play

**What plan are you on? - Regular $15 per month (annual)

**Does your plan include data, or just talk & text? Talk and text only

The backlight on my Moto Z Play usually takes 3 or 4 tries before it will stay on more than a second or two. Also, it often doesn’t come on automatically when I receive a call. Until that started a few weeks ago, the phone had never had any problems. Other than the backlight, it still works perfectly and holds a charge well. Once the backlight is on, it looks the same as usual. The only thing I’ve done so far is restart the phone. In fact, it always get turned off overnight.

The only other strange thing I’ve recently noticed is that the RW arc sometimes turns into a pyramid. That never happened before.

Any ideas?

  • I don’t have a Moto Z Play, but your comment “RW arc sometimes turns into a pyramid. That never happened before” does interest me
    • The next time this occurs, if you could do a 1 finger swipe down from the top and post back the verbiage in the Republic Wireless Notification?

Thanks for replying. It’s difficult to see sometimes because the backlight usually goes out before I can check out the notification. I have managed to see it a couple of times. It says I’m not connected to the network. There’s no problem with my Wi-Fi transmission since I can run YouTube videos without interruption when the backlight finally stays on and the RW arc is in place after the 3rd or 4th try.

If you could try one thing for me, it may help gather additional info on Doze which is Androids code that turns off our WiFi after some period of inactivity.
Download and install the Doze Detect macro that is published in Managing Doze Mode - (phone is on WiFi) calls via cell | calls go to voicemail | calls are missed

I’ll try that to see what happens, but everything suddenly seems to be OK now for some reason. After at least 6 weeks of problems, both backlight and RW connection are behaving themselves today. I noticed last night that the RW arc had disappeared altogether, yet the pulldown notification said I was connected to RW via Wi-Fi. There was nothing in the spot the arc usually occupies. After checking and seeing the same thing for a couple of hours, I ran the RW credential reset which I had done before with no improvement. The RW arc returned. Then, I disabled Doze Detect 0.9.4 in MacroDroid and reverted to my screen on every 50 minutes macro. On top of that, I got some updates for apps that hadn’t been updated for a while. So I don’t know which if any of these events apparently solved the problems. Maybe it’s the Pixel 3a I ordered. :wink:

EDIT: 0.9.65 Doze Detect now running


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer