Terrible reception on strong WiFi

What phone do you have? Moto 5g

What plan are you on? My Choice Talk & Texi

Does your plan include data, or just talk & text? Added 1GB for the month


Issue Description

Over the past week my phone reception has been terrible, even when on strong WiFi. Besides restarting my phone I am not sure what else to do. The cell has gotten worse, too, when in the same location that I was a week ago. Any thoughts or suggestions on what to do would be greatly appreciated.

Assuming that your poor WiFi performance has been limited to ‘at home’ there is always the possibility that a neighbor has updated their WiFi and are now causing you problems … or maybe they just rebooted their Router, which with most products set to default (Auto Channel Select) they grab the least busy channel … which could be the same one your on.

  • I would suggest you do Quick Start steps 1 & 2 found in Router Tweaks
1 Like

Thanks for the advice. I did everything suggested and still have horrible quality to the point where it is no use calling. I use Skype for working out of my home and have no issues with that which leads me to believe that it is my phone. The cell bars say “Emergency calls only” and the wifi icon keeps flashing the little up/down triangles. I never noticed the flash trianges before nor did I see the emergency notification. Any other thoughts? Thank you!

I too am very recently having some issues with call quality.

Try putting your phone in Airplane Mode, then turn WiFi back on. This will eliminate cell coverage and allow testing for WiFi performance without the possible interference of the combined cell/WiFi functions that Republic provides to improve call quality (in most cases, but if cell and WiFi are both marginal it can get messed up) The WiFi up/dn flashes is just an indicator that data is passing in both directions.

  • Does that make any difference?
  • If you could better define horrible quality, it might help … echo, choppy etc
1 Like

Yes, I put it on airplane mode, then turned WiFi back on, right away when it started happening. That was unsuccessful.

The sound is really choppy - people only hear bits and pieces of what I say and I only hear bits of what they say. Uploading the wifi analyzer results - I am netgear77 (blue)

Ok, on that the only suggestion I would make is to take the Channel Selection out of Automatic (if that is how it is set) and Select Channel 11. In the US only channels 1/6/11 provide separation … if you were on 11 you would be ~45dBm separated from breeze which is excellent (any thing > 25 is considered great)

  • This only tells us how strong the signal, so if you could now load Speed Test by Ookla this will give a bit more info

I think the issue is with the speed on my phone. If I use my laptop, the download speed is around 45-50Mbps, iPad 30Mbps and my phone is only 5Mbps(both download and upload). I routinely clear the cache, clear background apps and have plenty of space on my phone. Anything else I can do? I think the issue might have started when I added 1GB data to my plan. However, I do this routinely and have never had any issues. I have to be able to use my phone, and right now it is useless as an actual phone.

There may be some differences in the the results you have between the 3 devices … things you may want to check

  1. Each approximately the same distance from your router … speed can drop significantly
  2. Each going to the same end point (server) … Server & ISP are shown on 1st screen (press on the blue Server to change if necessary)
  3. Device on a different WiFi band? (2.4GHz vs 5GHz)
    • Phone-Settings/WiFi/NetworkName-SSID)
    • iPad … not available
  • When you run the test on your phone: What is the Ping, Jitter & Loss (these are tested and are the key attributes)

I just redid the speed test on on my phone I got the following:
download: 33.6 Mbps (great!)
Upload: 6.08 Mbps
Ping: 9ms
Jitter: 3mg
WiFi Band: 2.4 GHz

That looks good, and should support the RW VoIP.
You might re-run the Analyzer test and compare to the screenshot provided. Primarily to see if the 2wire376 has possibly changed channels (most router only check when they are booted up, AFIK)

2wire376 didn’t change channels, so I should be ok. There are lots of routers/wifi around me, but that isn’t new. One thing I have never noticed before is that my cell bars are full, but it says “emergency calls only”. I am at a bit of a loss with what to do next. I really appreciate the help thus far and any further suggestions! Thanks!

Thanks again … have you looked at How to Refresh the Republic Wireless Activation – Republic Help

Thanks for the link. I just reactivated and had a successful, albeit short, call. We’ll see how long it lasts. Thanks again!

1 Like

Ok, this is not working again. I really think this is my phone. There has been no damage to it, is there anything else that might be going on that would cause this from a hardware, operating system?

I guess I don’t fully understand if you are experiencing Cell or WiFi problems (or both)

  • After the ‘Refresh’ which reset both WiFi and Cell credentials with RW… what is the problem now?
    • Sometimes marginal WiFi combined with marginal Cell coverage as they attempt to provide us good service (by adding the 2 signals together) can result in choppy voice and or/dropped calls or complete handover to cell whenever its necessary
  • Does the WiFi work when you go elsewhere (like Starbucks)?

It also happens on strong WiFi outside of my home. Yesterday I was on a call and the reception started to get really choppy again, to the point that I had to end the call. I called the person back, putting my phone in airplane mode so it would not switch to cellular since that coverage was marginal. The wifi was very strong (50 Mbps) and the call continued to be choppy.
I have issues on both cell and WiFi, but mostly talk on WiFi because the cell coverage in my place is bad.

Have you tried disabling ‘handover on networks’ … it’s in the RW App Settings/Advanced Settings/Enable handover on networks and uncheck your home WiFi?

That doesn’t make a difference because it happens even when I disable cell ( enable airplane mode) and the reception is choppy. It is puzzling to me since it works great every now and then, but is crappy a lot of the time when no variables have changed. The phone feature is the only issue - no problems with texting, internet and other apps.

The suggestion to try disabling ‘handover’ is an attempt to see if the problem is caused by your phone, or possibly a result of Republics ‘Bonded Calling
Depending on the results of that ‘test’, the recommendation would then be go to the manufacture for warranty or to Republic.

Message an
Expert customer