Text going out on sprint number

This is on a new Pixel 3A XL with a CDMA sim using the default messenger. Texts are being seen as the underlying sprint #. I’m assuming this is a messenger issue. It only effects text. Calls are seen as Republic #.
If this is a messenger issue, what messenger should I install?

The default app on a Pixel 3A XL should get Google’s Messages, and that should work properly. Have you changed the app that you’re using? Does the icon for the app look like this :messages:?

No have not changed the Messenger and yes it looks like that.

Odd. Hmm. Well, my Pixel 3a XL should be coming in the mail tomorrow. I’ll post back once I get everything set up as to whether I have the same problem or not.

Sorry, I somehow missed that you had replied. If this is still happening, please open the dialer as if you were going to make a call and enter *#*#8647#*#* It should clear off the screen right after you enter that last star. Once that’s done, please restart the phone. Does this resolve the text message number issue?

I do have a help ticket open and they are working with me.
The ##8647## did not work. My next step will be to uninstall and reinstall the Republic app.

If we text a republic wireless phone the number is correct, but if we text a Google Fi phone we see the underlying sprint #. We have not texted any other carriers yet.

I just got my Pixel 3a XL up and running on Republic. I texted someone on Ting and the text came from my RW number, not my Sprint one.

That’s what would be expected and there are already lots of Pixel 3a users so the experience that @chadr.oalt70 is having is a strange one.

As of today the issue seems to be fixed. What fixed it, I’m not sure.

So this issue popped up again. I notice that if I turn off the Chat Feature in Messages on the Pixel 3A XL Republic phone I see the correct number on the google Fi phone. What are the issues if I leave the chat feature off? Should it work with the chat Feature on.

Interesting… So this is a new twist.

What’s happening is that Messages is recognizing the Sprint connection and enabling RCS via Sprint. Therefore messages to those on carriers that support RCS, and phones that support RCS are going out via that method. You might have noticed typing indicators and other “nice” things like that that come from RCS.

@southpaw This is likely something engineering needs to get Sprint to block for Republic service lines.

Hi @louisdi,

The best way to direct Engineering’s attention to the matter, is to create a master ticket, and for that, I’d need a few examples in member tickets. Is anyone else able to produce these same results?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Unfortunately, this topic was just closed today because I’m now experiencing the same thing:

My son just switched to Google Fi. When I tried to text him, it came in on the underlying Sprint number, so he wasn’t sure who was texting him. I’ll try turning off chat features and see if that helps.

If it does, can you please let us know?

Yes, turning off chat features causes it to come through via my normal RW number.

Thanks… I tried to forever to duplicate this and couldn’t get it to work. Have you been with Republic for a while or recently ported your number in?

Paging in @southpaw for awareness on this… the RCS thing we couldn’t duplicate

1 Like

I obviously haven’t had the 3a XL that long, but I’ve been with RW since the Moto X was added to the service back in the day.

I just looked. I’ve been with RW since November of 2013.

Message an
Expert customer