Text messages goes from a different number

What phone do you have? MOTO G5S PLUS

What plan are you on? 3.0

Does your plan include data, or just talk & text? 3GB DATA


Issue Description

When I text sombody , it randomly shows a different number than mine so sometimes people don’t recognize me. I have reset my republic wireless connection, also reset my cell network connection, but still the problem persists. Would someone can advise me how to fix this issue?

Hi @mathewk.mf87x1,

Please see if this sorts the issue:

3 Likes

Hi @mathewk.mf87x1 and welcome back to the Member Community. And if that doesn’t help here’s a text troubleshooting document that might help.

You can look through that and see if you have overlooked any recommended steps for the issue you have. And please come back here after review if this doesn’t help.

Thank you so much!! After toggled off ‘Enable chat features’ , text messages show my correct number!!
Truly appreicate your help!!!

5 Likes

I find this odd and curious what causes it?
I have RCS chat features enabled on mine any my mothers phones.
Text back and forth and to others show our RW number fine.

I have no idea what causes this problem, but after disabling RCS chat features, my issue has been resolved! Probably one of the experts can help us understand the reason why it’s happening…

As you know this RCS roll-out is being done by Google bypassing the carriers and without their consent or configuration. Because of this people are seeing weird things with different carriers from it only working on wifi, to it turning on and off constantly, to it refusing to activate when the phone is changed and other weird symptoms. On Republic the weird symptom is that for those configured with the GSM partner it works normally, for those on the CDMA partner RCS doesn’t work correctly with the wrong number being sent with messages that go by RCS.

3 Likes

Ah. That would be it then. Both ours are GSM. Thanks.

2 Likes

That make sense because mine was CDMA! Thank you for the additional information @louisdi!

1 Like

Yes, that’s correct! Mine was CDMA. That’s the reason why I had issues with texting…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer