Text messages require wifi access

What phone do you have?

What plan are you on?

Does your plan include data, or just talk & text?


I have had this problem and need it resolved, I have s moto g power, I am on unlimited talk and text.

However, when I try to send text messages it will not send unless I am connected to wifi. Yes I have use mobile data selected in the options.

Please follow the directions here: How to Disable the RCS Chat Features in Messages by Google – Republic Help (republicwireless.com)

Hi @terryo.i8etg4,

Please let us know if disabling the chat features in the Messages app resolved the issue for you. If it didn’t, I’d like to have one of our technicians work with you as we are seeing a handful of members who are unable to send SMS when they are away from WiFi and we need to work with someone whose phone is in this state to help us better understand the issue.

No still requires wifi to send texts

Please make sure that cellular data is enabled on your device. . Settings > Data Usage > Cellular Data (some phones may say Mobile Data).

As I said in my original post, allow cellular data us enabled.

Are you by chance using Data Saver?

Hi @terryo.i8etg4,

In addition to checking the data saver option that @louisdi has mentioned, can you also make sure you have a 4G or LTE symbol when you’re away from WiFi and the text message won’t send?

I’m opening a ticket on your behalf so we can collect some screenshots and phone logs so our technicians can look into the issue, so I’ll be in touch with you through our Help Center in just a few minutes or so.

1 Like

Data saver is off

Then I would proceed with the internal team as Southpaw indicated in her response to see if they can figure out what’s going on.

Hi @terryo.i8etg4,

Did you receive my message to you from our Help Ticket system?

1 Like

Yes I did, I have not been in any situation where I am off wifi to try texting, I have turned wifi off and was successful in sending a text, but I have not been able to try it away from my home yet.

Thanks for letting me know you did receive it. It will actually time out and close if we don’t hear back from you (plus, send you reminders that we are waiting for your reply). I’ll change the status of the ticket so it doesn’t keep pestering you.

That’s interesting. It sounds like the issue you’re experiencing may be coverage related, then, if you can send text messages over cell when you are at home.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer