Text messages sometimes won't show up unless I open messaging app

What phone do you have?
Moto G5S+
What plan are you on?
My Choice + 1GB
Does your plan include data, or just talk & text?
includes data


Issue Description

I’ve been having this issue more and more over the last 6 months or so, but it seems to have either gotten worse, or I’m just noticing it more and it’s becoming more annoying.

Text messages often won’t show up for me until I open the messaging app (Anywhere). This almost always occurs when I’m out of the house, away from my wifi. I also often don’t get a notification that I got a new text, so I won’t see it for sometimes hours or a day later, if I don’t go open the app.

Am I correct that RW runs on T-mobile’s network? I ask, because I figured that would affect how strong of a signal I would have outside of my home. T-mobile’s site says their network all around me is great, but it’s clearly not, at least not near me. I thought maybe I was driving around and was out of signal range when the texts came in, but when driving in the big city near me (Greensboro, NC), I should have had a good enough signal to receive texts, but I had one that did not show up until the next day, even after driving around. And I only saw it because I opened the app, as mentioned before.

Any ideas what could be causing this? It’s quite frustrating, and I’m tempted to look for another carrier, except in most cases that would mean buying a new phone, and I’d rather not spend the money yet.

Also, if you need more info from me, please ask. Thanks.

Hi @jumpymonkey9,

It’s possible this is a cell signal issue. To help us best help you, may we know the brand, model and generation of your phone? Not all Republic phones are provisioned for cellular coverage with T-Mobile. Some use or are capable of using Sprint.

You mention Greensboro, however, if comfortable sharing, your specific zip code (nothing more) might help narrow things down also.

1 Like

Hi, thanks for replying.

Do you need some info about my phone more than what I mentioned in my first post? I don’t have any info about a generation version that I can find. I’m assuming they only made one.

My zip is 27263. Not Greensboro, but I just happened to be driving around there that day. The cell signal in my home is usually pretty poor.

Thanks.

You’re welcome!

No further information on that needed, I simply managed to miss you had supplied the info.

Coverage for both of Republic’s network partners appears to be good on the maps. Let’s see whose network your G5S Plus is provisioned with: Here’s how:

  1. Open the Republic App
  2. Tap the gear icon upper right
  3. Tap About
  4. Under the Phone Info section, your phone’s SIM type will be listed (GSM or CDMA)

GSM = T-Mobile, CDMA = Sprint

1 Like

Can you elaborate on this comment? Are you saying that the messages start loading up into your Anywhere app when you open that app?

Have you tried Messages by Google ? Does it give you the same experience?

My phone uses GSM.

amitl, when I open the Anywhere app, the messages will then show up. This doesn’t happen all the time, but it’s happened a few times. I won’t get any notification from the app that I have a new message. So maybe it’s there before I open it, but I don’t realize I have a new message until I open the app. But I do recall at times seeing messages pop up upon opening the app, just not that often.

I have not tried Google Messages. Would I need to set that to my default app to be able to test it? I don’t want to start changing things yet if possible, to be able to narrow down what’s happening.

There are some pockets of not so great GSM coverage in and around Greensboro. If you happened to be in one of those pockets, it might explain the experience. Here’s what can be tried to see if GSM coverage can be “fixed”:

  1. How to Refresh the Republic Wireless Activation – Republic Help.
  2. How to Reset Network Settings for Motorola and Google Phones on Android 8.1 Oreo and Android 9 Pie – Republic Help

If what I’ve suggested above doesn’t change Anywhere’s behavior, this is a worthwhile suggestion to attempt to isolate whether the issue is with Anywhere or your coverage.

Yes.

1 Like

From your original post

Is it often or is it always…if you are not receiving any notifications…then you may want to
double-check your Notification settings for the Anywhere app?

Settings -> Apps & Notifications -> Anywhere
Tap on Notifications
Tap on “Other Notifications”
Tap on Behavior

Thanks for the help so far.

I refreshed my RW activation. I want to wait on resetting the network settings, since that would erase all my saved wifi info. If these other steps don’t work, I’ll try that also. I also changed my default app to google messages. We’ll see how that works.

As for notifications, I was still getting them, just not for every text. It’s been that way for a while now, maybe a year or better. I always rely on looking at my phone to see if it’s lighting up with notification of anything. If it’s not lighting up, I assume I don’t have anything new. But then I’d open the app, and there would be new texts. Again, that was with the Anywhere app. And again, it wasn’t always the case. For now we’ll see how the other app does. Thank you.

2 Likes

What you are describing is the Moto active notifications or Moto Display features.
If you are not getting them while away from WiFi…then you might have blocked background data access for the Motorola Notifications app

You can check that under
Settings -> Apps & Notifications -> Motorola Notifications -> Data Usage

And make sure that Background Data is enabled

I checked the settings for the Moto Notifications app, and it says Background data is enabled. And Unrestricted data usage is on also.

I do have Data Saver on, since I was running out of data before the end of the month, even though I didn’t seem to be using anything out of the ordinary. I get that some apps just use a bunch of data in the background.

Thanks for continuing with the tips. I’ll keep you all posted if anything changes, or even if it doesn’t change.

1 Like

Hi @jumpymonkey9,

Could you please open the Settings app, tap Sound, and tell us what it says right under Do Not Disturb preferences?

You are specifically referring to the icon at the top of the screen - it does not appear at all, even silently?

1 Like

Under “do not disturb” it says “No automatic rules turned on”.

Yes, I’m referring to that icon, and the associated one that appears on the screen when sorta “wakes up” when I move the phone. If I move the phone, the time, date, battery life and any new notifications will show up. If I unlock my phone, those notifications will stay at the top bar on my phone, but won’t be on the “semi-off” screen. I don’t know what to call it. It’s not the lock screen, since I have to hit the power button to show that. I hope that makes sense.

Hi @jumpymonkey9,

Let’s see if we can make sure we’re speaking a common language, then maybe we’ll have more insight to understanding where to troubleshoot this.

It sounds like there are three places you can view notifications.

  1. Active notifications. The icon is on the screen that fades in and out when the phone is sleeping and can be seen by nudging the phone.
    image

  2. Lock screen notifications. This is where you’ll see notifications when you press the power button, but before you swipe up or enter a PIN/password/pattern to unlock the phone.
    image

  3. Notification tray. This is where the notification icons line up at the left top of the screen and can be pulled down with a one-touch swipe for more details.
    image

I’m not sure from what I’ve quoted whether you mean that the text message notifications are showing up in some of the places but not others, so just to make sure I’m fully understanding, tell us if your text notifications are showing up in any of those three locations, which ones, and all the time or just some of the time.

Maybe you can copy and paste this table and edit the :heavy_check_mark:s and :x:s to give us a better understanding.

Text message notification Active notifications Lock Screen notifications Notification Tray
Always displayed :heavy_check_mark: or :x: :heavy_check_mark: or :x: :heavy_check_mark: or :x:
Sometimes displayed :heavy_check_mark: or :x: :heavy_check_mark: or :x: :heavy_check_mark: or :x:
Never displayed :heavy_check_mark: or :x: :heavy_check_mark: or :x: :heavy_check_mark: or :x:
3 Likes
Text message notification Active notifications Lock Screen notifications Notification Tray
Always displayed :x: :x: :x:
Sometimes displayed :heavy_check_mark: :heavy_check_mark: :heavy_check_mark:
Never displayed :heavy_check_mark: or :x: :heavy_check_mark: or :x: :heavy_check_mark: or :x:

I think this answers your question. I just wasn’t sure on the terminology for the various notification areas.

I will say, since I’ve been using the Google messages app, I haven’t had any trouble. But I also haven’t been leaving the house, and thus my wi-fi, very often. I’m going to keep an eye on it though. I’m not really sure how to follow up on this unless I start having trouble with this app. I really don’t want to go back to the Anywhere app. Thanks for your help so far.

1 Like

Hi @jumpymonkey9, just checking in to see if you are continuing to have a consistent texting experience since your switch to Google Messages.

I experience these missing notifications on my PC. Every now and then I go into Anywhere and find a new message I was never notified about. Also, when I am notified and click on the notification to read the message it will sometimes take me to the message, sometimes not. Unfortunately RW tells me they are no longer developing Anywhere. They suggested putting the inferior Google Messages on my PC.

Message an
Expert customer