Text notification problem

What phone do you have? Moto G6 Play

What plan are you on? My Choice

Does your plan include data, or just talk & text? Includes data

Issue Description

Just yesterday, 4-18-19, this problem started. When I get a text message and I swipe up to open the message, the first half of the notification tone repeats anywhere from 4 to 20 times before is stops. The message opens but it is very annoying sounding like a broken record. I shut the phone down and turned it back on, but that did nothing. Can you help me?

There are reports of this happening to others after updating the Moto Display app (latest update was 4-17-2019). Here’s what happens on our two Moto G6’s with Oreo. Ever since last update the notifications go crazy when viewed through the top “Peak Display” screen enabled in Moto Display.

Example: Receive text message and get a notification sound. Press and hold text icon on Moto Display screen and slide up. Text message opens and the system notifications goes crazy. Sometimes 15 or more notification sounds in a row every time.

If we turn on display by tapping power button, swipe down on notifications and go to the text message, system works with no extra sounds. Tried all kinds of app settings in both Moto and Google messages, cleared app caches, restarted phone and still have the problem.

Reverted back to older (factory) version of Moto Display and “Peek Display” works perfectly. Not a single extra notification sound! Went in and disabled automatic app updates in Google Play so the system does apply the update a recreate the problem.

We reported this in the app reviews and sent E-mail to Moto developers. They responded confirming receipt of message but will be out of the office through the holiday weekend. Anxious to see what they recommend. Maybe others in this forum may have another resolution.

1 Like

How do I revert back to older (factory) version of Moto Display?

Sorry to take so long responding. Had just logged off and called it a day and missed your question. Here’s what we did.

Settings>Apps & notifications>App info make sure it is set to All apps. Scroll to Moto Display and tap to open. Now tap three-dot menu in upper right-hand corner and select Uninstall updates. Should now be back at Factory version.

Don’t think I missed any steps. This is an abbreviated version of the steps described here -

The article has lots of other information like going on to install the version you want. No need to install anything because you just rolled back to the built in factory version in Oreo. Recommend a quick review of the article to get an idea what’s involved.

After you’re done the Google Play Store will show there is an update available for Moto Display. We turned off all automatic updates so the app doesn’t get updated. We chose to turn off updates for all apps but think you can disable updates by app. Hope the developers find the problem and update the app so we can go back and on enable auto updates.

Hope this helps.

Thanks so much. I think I got it!

1 Like

Well good news…I think. Just installed the Moto Display app update from today (5-6-2019) on our Moto G6’s and the multiple notification sound issue appears to be fixed! Will continue to test and use and report back if there are any issues. Now we can go back and turn on automatic app updates.

Thanks, I’ve watching, hoping a fix was coming soon. I’m going to try it right away. I appreciate those who know how to handle these problems and who to go to with them. Thanks again.

1 Like

When the previous app was installed I got a notification when the screen was black before I turned the screen on. Since the fix I’m not seeing that anymore. I really liked that feature and when I go into the app information, and under store look at the app details where it says Read More, it says “Moto Display gives you what you need to know, when you need to know it - without waking your phone. Information discreetly appears on the screen, so you don’t have to turn the screen on to look at the time or see notifications.” I’m not getting that now. Do you have any idea what I’m talking about and what I can do to fix it? Thanks again.

@bonnies.bekeak – in the Moto app features tab we have both Peek Display and Attentive Display turned on under Moto Display. There are also some additional settings under Peek Display and Attentive Display.

We also have Sleep set to 1 min under Settings>Display>Advanced so we have some time to react yet shut off the display reasonably quick to save battery.

Recommend you check some of these settings and see if it helps.

1 Like

A few days ago I finally followed your instructions and it was exactly what I was looking for. Thanks so much.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer