Texting sms disabled

I bought a new moto pure edition, it says messenger is my sms app for texting but sending is disabled, when I use messaging he text works fine but my phone says this won’t work with republic. any thoughts

From what you have described you want to set Google Messenger as the default which, in turn, will disables Messaging. Whichever one is set as the default disables the other one.

go into setting /" Wireless &network" More menu

tap the Default SMS app and change to Messenger (the one with a text bubble in the blue icon)

Message an
Expert customer