Texting - Text not sent, -

Can not send Text, “text not sent”
opened Rep. app, no gear on upper right

We would need to know more information about your issue in order to help.

What phone model do you have?
What messaging app are you using?

Here is Republics pages for help on Text message issues:

moto e4 messages sms

Check in the Play Store to make sure both your Republic App and the Messages by Google app are updated.

have you tried any of the things listed in that help article?
You would need to follow the options listed for Republic 3.0 phones.

I have tried this

  1. Connect to WiFi
  2. Open the Republic Wireless app
  3. Tap the gear icon in the top right
  4. Tap Advanced Settings
  5. Scroll down and tap Reset Republic Connections
  6. Tap Reset Connections
  7. Tap Done When I oprn rep. app there is no gear icon in top right

Have you tried rebooting the phone?

Also, I do not see those instructions you posted in that Troubleshooting Text messages document I linked to. Reseting the Republic connections may not fix an issue with the texting app it slef.

Have you tried any of the steps listed under " Things to Try on Your Own" such as:

Clear out all old messages from the Messaging or Messages app

Clear the Messaging app’s data

Reset Republic Wireless app settings

Many of those do state to reboot the phone after performing the steps.

OK I will give it a try, thanks

All fixed, Thanks

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer