Texts don't receive images (Moto E 2nd Gen)


#1

I have an iPhone through work. My wife is on RW with a Moto E 2nd Gen phone. My texts to her come through fine, but if I text her an image, she doesn’t get it. She’s connected via WiFi when at work, and same as at home, but no images will come through. Tried twice today. Any thoughts on why this is happening?


#2

May I ask what carrier your iPhone is using? Also, have you ever been able to send MMS messages (picture messages) to your wife’s Republic Wireless phone, or is this a recent issue? Lastly, was your wife ever an iPhone user (see How to Deregister from iMessage)?


#3

I’m going to take a guess. If your wife still using the original Messaging App on her phone? If so, that’s likely the cause. It has been a while since that app has been in active development. If your wife install Google Messages you’ll likely find the issue resolved.


#4

Thank you for the two replies. My iPhone is set up with Verizon. My wife’s RW phone is her first cell phone, so she’s never had an iPhone account previously. Yes, she is still using the original Messaging App. I could try downloading the Google Messages app and see if that makes a difference. One odd thing that happened late last night is that a mutual friend sent a group text to my wife and I with a couple photos of our son with their son. My wife received the photo from her no problem. Weird.


#5

I certainly recommend using Google Messages. In addition, here is some info from Verizon. Perhaps it has to do with the file size of the image:

https://www.verizonwireless.com/support/knowledge-base-14641/


#6

Interesting. I didn’t know that. So if I download Google Messages to her phone, and she starts using that, is there anything I need to do to deactivate the native app so that messages go to the Google app? Or do I just download and you’re good to go?


#7

You’ll want to make sure after you download and open the app, that Google Messages is the default messaging app:


#8

We’ll give that a try. Thanks!


automatically bumped #9

#10

Hi @shawng.gcqhil,

Was the issue your wife was experiencing with being unable to receive images by text message solved with the Messages app by Google?


#14

The texting seems to definitely work better, although there still have been times when I’ve sent texts to her with a photo that did not come through. I think it could partly have to do with the WiFi she’s connected to at work interfering in some way. The other day I sent her a couple photos in a text and I talked to her a couple hours later and she said there were no texts from me. However, when she left work and got into her car (which is a GMC with a built-in WiFi hotspot), all my texts suddenly came flooding through. So, the texts wouldn’t come through on her work WiFi, but came through as soon as she connected to the car WiFi. Weird.


#15

Hi @shawng,

Thanks for the follow-up!

This!

MMS (text messages with photo attachments, really long texts, or group messages) and voicemail notifications are delivered over Wi-Fi by a protocol call MQTT, which some office Wi-Fi networks block. If you want to be sure the issue is the Wi-Fi network and not the phone, try leaving her voicemail while she’s at work. (She’ll have to be advised you’re testing, and encouraged to dismiss or ignore your call). She’ll likely see a missed call notification, but no voicemail notification.