Texts not sending, phone calls going to wrong numbers in contacts

What phone do you have?
Moto X4, Moto X4, and Moto E4Plus
What plan are you on?
Yearly
Does your plan include data, or just talk & text?
Just talk and text


Issue Description

I’ve been having problems with people not receiving texts that I sent. They just don’t get them.

Also I’ve been having a lot of trouble with texts not sending at all on my phone, and it requiring a reboot to send the texts.

Then there’s another problem I’ve been experiencing with phone calls not going to the numbers dialed. When I tried to order food from a local bar on the telephone for pickup, it kept dialing my home number! Even though the number as dialed looked correct, it kept trying to call my home phone.

For the text problem, I would make sure that RCS Chat Features in Messages by Google are disabled:


I’m not sure what to make to the phone calls not going to the number dialed. Do you have any call blocking, call recording, or alternate dialer apps on your phone? They can sometimes cause problems.
1 Like

I have no call blocking, call recording, or alternate dialer apps on my phone.

I also went into the Google Messaging settings as the article you linked me to suggested, and the toggle for “Enable chat features / Use Wi-Fi or data for messaging when available” is off already.

My mother and father are also on Republic Wireless phones (which is why I listed all 3) and they have had problems with not receiving texts that family or friends have sent, or having their text messages not received by other people they were trying to message.

Just to be clear, there are 2 separate text message issues,

  1. Messages not sending/failing and having to reboot the phone to get them to send.

  2. Messages saying they have been sent from our phones in the text conversation, but they do not get the text

& 3. Not receiving texts from family and friends that they had sent and that show up in their conversations in their phones, but we don’t get them

Only reason we even know about 2 and 3 are because of either multiple message texts which only show up with part of the message or out of order, or family or friends getting angry at us for “ignoring their messages/not replying.”

Hi @potatoes,

You have a lot of issues listed. It’s very hard to troubleshoot multiple issues on multiple phones at once. It gets very confusing as to what’s been tried and on what phone.


Are calls from your phone to your local bar still ringing your home phone? For that issue, please refresh the Republic activation, then re-test. If the issue persists, you’ll need to open a Help Ticket about that issue specifically, giving some examples of the number you are calling from, the number you are calling to, and the time of the call, so the issue can be investigated by our number routing partner.


The next time this issue pops up, where you’re having trouble sending a text message from your phone, before you reboot the phone to “fix” the issue, please make a mental note of the following details:

  • Is the phone on WiFi or Cell?
    • If it’s on WiFi, what kind of network are you connected to? Home, a business, a network with a captive portal? Are you able to open your browser and surf to a website that you’ve never before visited?
    • If It’s on cell, do you see the LTE symbol at the top of the screen? Are you able to open your browser and surf to a website that you’ve never before visited?

Let us know the answers to those questions. I’m suspecting poor cellular coverage may be a factor.


If these issues persist after we determine whether there’s a call routing issue and after we evaluate any possible coverage issue, then this is something that our technicians would need to look into with recent examples much like the call example I described earlier.


I’m not asking you to go now and open a help ticket describing all of these problems. Let’s look at them one at a time, moving each one individually and methodically to support if needed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer