Thanks for the EASY move from GSM to CDMA

#1

My spouse was having poor coverage on the GSM partner at our house. She moved to a Moto X4 from a Moto X2 (which was CDMA). They shipped out the SIM card with instructions and a SIM removal tool.
It was easy to replace! At first I could not make phone calls or connect to data away from wireless.
The only thing I would add to the one page instructions sent are the following:

  1. Reset Cellular Settings:
    How to Reset Cellular Settings on Motorola, Nexus, and Google Phones with CDMA SIM Card – Republic Help
  2. Perform Data Profile Refresh:
    How to Update the Data Profile on CDMA-Active Motorola and Google Phones Running Android 9.0 Pie – Republic Help

After I performed those 2 operations everything worked like a charm!
Thanks Republic Wireless for all you do to simplify things like this!

6 Likes

#2

I second the motion I switched back to CDMA on my X4. It seems like my phone is connect now. The GSM would leave me stranded with no cell service or texting at Home Depot of all things. Many other places too I had to find WIFI and continuously VOIP my phone which seemed like every day but really it wasn’t.
Thanks RW Help Team for making it simple.

0 Likes

#3

Sarah B.

Sara B. in Support took care of getting me a CDMA SIM card for my recently purchased Moto X4. I wanted it for my up coming travel plans, opened a ticket on Friday last week and it arrived on Monday. Great job done by support and it was appreciated.

A bit of a PIA activation, initially had no cell and unable to make WiFi calls. Phone apparently thought it still had a GSM SIM, removed and reinstalled RW app and then phone recognized the SIM was CDMA. Still unable to make calls and ended up having to Reset Network Settings.

:flight_departure:

0 Likes

#4

Hi @PlaneTherapist,
Your experience may have been prior to our research on this matter, but we do have a Help Article specific to what you went through, and are investigating the issue with Motorola.

For others looking at this topic, I want to be sure they are aware that the issue can be resolved by toggling the network mode.

While resetting network settings will also resolve the issue, the toggle approach will not delete all saved Wi-Fi networks.

0 Likes

#5

Hi @southpaw,

I’m glad the procedure wasn’t available, read and followed to the T yesterday. Factory reset also resets the network settings which seems to be the fix.

I just tried the swap procedure again and after changing Preferred network type kept getting the persistent ‘Configuring your cellular network’ notification on the phone. After Resetting network settings I changed Preferred network type back to LTE.

Resetting network settings fixed the issue again would be the preferred method to most members rather the nuclear Factory Phone reset.

RW Support may want to investigate further and make a change to their article.

:flight_departure:

0 Likes

#6

Hi @PlaneTherapist,

Thanks for the thorough follow-up. Our team has had consistent success with toggling the network type, but given your experience, have updated the help article to include the information you provided. Thank you.

0 Likes

#7

Persistent ‘Configuring your cellular network’ notification on the phone

Hi @southpaw,

Update for you, a day later I’m back to getting the notification when trying to make a phone call. Incoming calls seem to come through. Going back to using my GSM SIM for the time being so I don’t have to reenter my networks info again and try the Factory reset.

Also have had a dramatic increase of battery drain for the couple of days using the CDMA SIM. Phone was fully charged at bedtime and 7 hours later it was down to 50%. Battery usage didn’t show anything unusual.

:flight_departure:

0 Likes

#8

I never did the “Toggle Network Type” on our X4, I only did the “Reset Cellular Settings”, and “Data Profile Refresh”. It seems to have held up fine since I did it a couple of days ago. I did not have to re-enter all my WIFI settings either. Hopefully you can get it to work without performing a “Factory Reset”!
Good Luck!

1 Like

#9

Thanks for the info @muerte33 and glad to hear it seems to work. I’ll give those a shot. I should have reread your initial post.

:flight_departure:

0 Likes

#10

When I did the CDMA SIM installation on my mom’s X4, it was pretty smooth once I did the network settings reset. On my X4 however, I was without cell for about 16 hours. While I was taking screenshots for my support ticket, I accidentally bumped the roaming setting to off, then immediately turned it back on, and suddenly cell service worked.

0 Likes

#11

Some time ago, as part of trouble shooting some call quality issues, RW sent me a CDMA SIM for the phone I had at the time, a 1st gen Pixel XL. I could not get LTE to work ever after a network settings reset and re-install of the RW app. Calling worked, texting did not, and the phone would connected to 3G briefly, then drop to Edge. I know that I have a useable enough Sprint LTE signal in my home and surrounding area…Seemed like a provisioning issue maybe.

I recall reading else where that activating a device on a pre-paid Sprint plan or Sprint MVNO has issues of some sort if the device was already used on Spint Post paid (or was it the reverse of that?? i cant recall) either way, my Pixel had already been used on Sprint Post paid, and on Project Fi.

Anyway, I was able to do the call quality test I needed, then switch back to the my GSM SIM just fine and with no issues. I was on Sprint Post paid plan before coming to RW and while, Sprint network was a bit better than I had thought it would be, it was far inferior to Tmobile overall, and lacked many useful features that one takes for granted these days…it was like I was stepping back in time 10 years when on Sprint.

0 Likes

#12

hi @muerte33,

Just wanted to thank you again. This evening I reactivated my X4 on CDMA following your added suggestion to the instruction sheet. All seems to be good to go without having to do the network settings reset again.

:flight_departure:

0 Likes

Message an
Expert customer