Transfer number from Google Fi?

Hi, I’m trying to transfer my number BACK to Republic from Google Fi, but Google Fi is not on the list of carriers to transfer from. I have the Account number and PIN, but I can’t continue the process because I need to select a carrier.

What should I do?

Just pick one of the others. I did the same, and Fi got the memo in a couple of minutes.

See step 7: https://help.republicwireless.com/hc/en-us/articles/115005636388

Please note that you will have to create a new RW account to activate, as directed here: https://help.republicwireless.com/hc/en-us/articles/4416732446103-How-to-Activate-5-0-SIM-Cards-That-Were-Bought-On-an-Existing-Legacy-Including-My-Choice-Account. I am in the middle of the same process.

2 Likes

I’ve already created a new account and had to buy the plan TWICE because of some stupid thing on RW side. I’m now on the phone with tech support, and they told me the same as you (pick any carrier), which I did. But there’s a new and exciting problem:

I can’t even transfer my number from Fi at all! It comes back as an invalid number. Customer service says that it’s because it’s a VOIP service. and something something something.

I’m starting to wish I hadn’t gone with RW at all.

That’s new. Admittedly, my number started with RW, moved to Fi, and is trying to come back.

To your larger point, this 5.0 rollout has more in common with satellite TV customer “service” than typical Republic easiness. It’s been 4 hours since I submitted for activation, and it’s still radio silence. Could be in phone limbo through Christmas. If you haven’t cancelled Fi, I suggest waiting until this is all figured out, and it’s not just me: 5.0 activation reports? - #6 by southpaw

1 Like

Hey, you sound like me. I started with RW, moved to Fi, and am trying to get back to RW.
I told Fi I was leaving, but they won’t shut off the service until it’s transferred, so I guess I’ll just hold for now.

Thanks!

You’re welcome. Once this is all straightened out, I can send you some pointers, if I have any.

1 Like

Customer service is incorrect on that. You might want to tell them Google Fi numbers are T-Mobile MDNs. They may be confusing Google Fi with Google Voice. Google Voice numbers are VoIP.

3 Likes

Hi! It’s MiniLaura with a new account!
Anyway-- Although @southpaw is hoping for positive responses, I’ve been having the worst time trying to come back to RW.

  1. I followed the directions, set up a new account, ordered my plan.
  2. I got my SIM cards, stuck them in the phones, tried to activate, but I couldn’t get an activate button on the activate screen.
  3. Spent almost an hour on the phone with customer service trying to figure out why I didn’t have a button. Ended up being to told try again the next day.
  4. Tried again the next day, same problem.
  5. Opened a ticket.
  6. Got a stupid response saying that there was no account associated with the ticket (though how could I open a ticket without an account?!)
  7. Responded giving old account info.
  8. Was told (basically) “We had an oopsie. Please buy the plan again, then you can activate your SIMs.”
  9. Bought the plan AGAIN. Started the activation process. Got to the transfer number screen. Followed the steps (picked any carrier, put 1 for Apt number, etc).
  10. Got a response that the number (which started with RW!) was invalid or did not exist.
  11. Was on the phone with customer service for another 25 minutes to be told “Oops. Maybe it’s because Fi is a VIOP service? Maybe try again later.”

I’ve never had so much trouble with RW before. I’m so frustrated.

2 Likes

@Mini.Laura

I had the same “invalid or did not exist” problem and worked around it by trying a different browser (that I don’t normally use). See my post right above yours.

2 Likes

I read that, but I was already using Chrome. I guess I’ll try something else later. I need breaks from dealing with technical support.

@minilaura , I’d recommend trying any other browser than what you had been using. Maybe even a different device, if possible. I suspect that’s what was going on with my situation – there was something fouled up in my normal browser, and once I switched to a “clean” one, things just started working as you’d expect.

1 Like

OMG. Your solutions worked to–up to a point. :fearful:

[REMOVED screenshot that said “Please Contact Customer Care”]

1 Like

Ha! Well glad it got you somewhere at least. I don’t think mine said Please contact customer care but I’m not positive. I was also only activating one phone number… who knows if that could be part of the issue.

2 Likes

This is a public forum. You may not want to expose your phone numbers.

1 Like

oops. Thanks!

Blockquote Theoretically, your My Choice SIMs should continue to have service until the port completes.

Nope. My husband who had a 4.0 plan tried to port the number to a 5.0 plan, it failed. And when he put his 4.0 SIM in, it said that it wasn’t activated on Republic