Trouble sending/receiving texts when not using WiFi

What phone do you have?
Moto x4
What plan are you on?
Unlimited talk/text

Does your plan include data, or just talk & text?
Just talk and text


Issue Description

The problem of not being able to text, when not on WiFi has been going on for years. Was sent a different sim card, but that didn’t work. Although I do not have a data plan, I have mobile data turned on.
Once in a while I can text when I’m out and about, and not using a WiFi signal. And like yesterday, when I could not text, I was able to make a phone call to the same number I was trying to text to.

I thought texting took less of a signal than calling.

If you’re using Messages by Google, be sure to turn off RCS chat features. RCS chat would require a data plan or WiFi connection to send messages.

1 Like
  • There is also the possibility that you may be in a ‘roaming’ coverage area?
    • Make sure that both cellular data and roaming data are turned on in the Android Settings and the Settings in the Republic Wireless app have been set to notify you if either is turned off.
    • RW App / Settings / Advanced Settings/ Show cellular data disabeled & Show roaming disabled
1 Like

Hi,

Thanks for the tip. The chat feature was enabled, but turning it off and restarting the phone didn’t fix the issue.

Hi @tileguybythesea,

Welcome to our Member Community, and that is a great username.

Texting on the My Choice plan requires a data connection - either WiFi or cell. This does not mean you have to buy data in order for texting to work - the Republic app allows the data required to send and receive text messages even when you have no purchased data.

What you’re remembering (less of a signal than calling) was true on older phones.

If RCS is disabled (it requires purchased data) and roaming is enabled, can you describe the connectivity of the phone? Do you see a 3G or LTE icon?

Hi,

Thanks for trying to help me out.
Roaming was off, so I turned it on. Didn’t fix the problem.
I think my phone is lte, but I do not see either the lte or 3g icon.

Scott

Thanks for checking the roaming setting, @tileguybythesea,

Just to be sure, is cellular data also enabled?

If neither icon is present, either cellular data is turned off on your phone or you are not in an area where cellular coverage includes data. You do appear to have the better SIM card for your area.

We are investigating an issue where a handful of members are experiencing a failure to send text messages when they have no purchased data, even though the purchase of data is not required for text messaging. I don’t want to lump you into that investigation until you can confirm that you cannot send or receive text messages when cellular data is available to your phone (with a 3G/4G/LTE icon).

Message an
Expert customer