Two-factor codes from USPS not reaching the phone

I suspect that I have encountered the same problem but with a different government site. The US Postal Service (USPS.COM) now requires you to create an account before you can schedule a mail hold. The account creation process requires them to text a verification code to your mobile phone, but that fails with my RW phone. Reading their “fine print” it does say that “landlines” are not supported.

It also gives me the option of going to the local post office and doing this identity verification process in person, so at least I have an option. But this is kind of a pain in the neck and I expect that it will only get worse as more entities start requiring 2FA. I understand that it isn’t something that RW can fix, but it might become a decision factor for RW users at some point down the line.

1 Like

I’m able to successfully receive codes from USPS for my previously created USPS account which did not require me to enter my cell phone at the time of creation. I added my cell number just now and received the verification text. There is not enough information to determine what is going on here. It would be interesting to see if a) you’re able to inconsistently receive the texts and b) what other people’s experiences are.

Interesting. I’ve tried multiple times with no success. I am using RW’s GSM carrier, although I doubt that this makes a difference. I just requested that the code be sent to me via standard postal mail, as that is the only other option.

1 Like

Hi @fisher99,

Do you have a ticket open with some samples of date and time when you tried but did not get a message from the post office?

(Edited - didn’t read far enough up the thread to initially realize you’re experiencing this with the post office.)

I had the same experience. Snail mail verification code worked for me.

1 Like

@southpaw:. No, I haven’t opened a ticket. I submitted a request to USPS for a snail mail verification.

1 Like


I also attempted to sign up for an Informed Delivery account with the Postal Service. My reading of the account verification process is slightly different than fisher99’s.

Once you enter all your information, you are asked to verify yourself by providing your phone number. If you cannot do so, you are told to avail yourself of a verification code sent to the address for which you want the account. That’s what I had to do, and it worked fine for me.

What I recall happening, after entering my phone number and pressing the button, is getting an on-screen message that said my number could not be verified. I assumed this was based on some kind of a lookup, not an attempt to text me, but that might not be correct. If so, however, it’s certainly an issue with “my” number and the underlying T-Mobile number.

As you see from the other posts, once you get the account set up using the snail mail verification letter, all seems to work well, again leading me to think that there’s not an inherent issue with texts.

1 Like

I don’t believe this is a matter of Republic’s numbers being classified as wireline (VoIP). I believe it’s a matter of Republic being a prepaid service provider. Because prepaid providers don’t do credit checks, prepaid numbers are generally not seen as providing identification of who owns them.


It has been a a couple years now since I had signed up for that service, had no issue getting the SMS code from them. Maybe something has changed since then.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer