Unable to Activate Alcatel A30

Hello, I recently got a backup phone - an Alcatel A30.
I am an existing Republic customer with a main account.

I am trying to activate the phone as a second line in my main account.
I ordered and inserted a SIM, connected to Wifi, downloaded the republic app.
However when I open the app and click activate, it sends me to a screen describing 4 steps (like checking phone compatibility, getting SIM etc. ) and it says you can sign in to your account to add a line.

So after signing into my account and clicking add a line, I just get a popup (see screenshot) and I can’t seem to actually activate the phone.

I have an open ticket with support but they’ve only suggested:
An activation reset: ( *** # * # 8647 # * # ***), and
Uninstalling and reinstalling the republic app

Neither of which worked.

The phone is a 5045G model and the republic app version is 3.30.0.82 so that should be fine.
The android version is 7.0.

Tech doesn’t seem to know what’s up, so I thought I’d try the forum.
Please see the screenshot for more details.
Any help would be greatly appreciated.

Hello @jRepublic,

It looks like it might be the model number of the Alcatel you have that is the problem. Per this Republic page, the 2 model numbers supported are 5046G and A576RW :thinking:

Hello, thank you for the response.
My phone is the 5046G (for GSM), not the CDMA version so it should work on the Republic (T mobile) Network
Thank you

Hi @jRepublic,

We’re investigating a bug in the Republic app where some phones are failing to recognize that a Republic SIM card is installed.

Would you mind sharing a screenshot showing the model number of the phone? It seems there’s some confusion about that in your ticket.

If the phone is compatible, we may be able to get you activated by moving you to an older version of the Republic app. I’ll be glad to try that by DM with you after confirming the phone’s model number.

2 Likes

@jRepublic,

We were able to have someone else test the steps I sent you earlier about the SIM card. Could you please try the following, instead?

  1. Long press (tap and hold) on the RW app icon
  2. Tap App info
  3. Tap Permissions
  4. Enable the Phone permission

Then re-try activation.

2 Likes

Hi @southpaw - thank you so much for the followup and help.

That solution (enabling phone permission for the app) worked! I was able to activate and add the line.
Note: just for documentation purposes the removal and reinsertion of the SIM while the phone was on didn’t work

I had a ticket (that you might have seen) open for this topic - I will mention this solution and close the ticket.

Thanks again for the help - I really appreciate it.

1 Like

Thanks @jRepublic, your confirmation that those steps resolved the issue will be a big help to us!

1 Like
Message an
Expert customer