Unable to Connect to Home WiFi after a System Update


#1

I have seen reports of some phones having WiFi issues after recent system updates. This seems to be most common in the Moto G4, but I am also seeing it in the Moto Z Play. So if you have had a recent system update and were able to connect to a WiFi network previously without issue, but now you can’t after the update I recommend checking to see what security standard you are using for your network. If you are able to connect to other networks, but not the one in your home, this is a huge clue. I am not sure if this is linked to a certain date Security Patch from Google, but is 100% related to the router using WEP for the wireless security protocol. WEP standards for Wireless Security Privay. It is a rather outdated security standard and in my opinion isn’t much better than just leaving your network open (without a password). For those that are interested in reading more about WEP : https://www.lifewire.com/definition-of-wired-equivalent-privacy-816575

If the symptoms I described sound like something you are going through, I would recommend you see if your router is using WEP security and change it to WPA or WPA2. With there being so many routers variations out there, it is difficult to cover them all, but here are some links for major brands that should help.

Netgear: https://kb.netgear.com/13111/Securing-Your-Wireless-Network-WPA-PSK
Linksys: https://www.linksys.com/ca/support-article?articleNum=139152
TP LInk: http://www.tp-link.com/us/faq-399.html

For other routers, a Google search (or your favority search engine) of “Change wireless security settings of…” and the make and model of your router should help you get instructions on how to change the security settings. I would recommend you use the latest standard for WiFi security protocol which is WPA2 if that is an option for your router. If you have some older hardware that hooks up to your network, WPA2/WPA Mixed Mode would also work.


Wait for RW or go for sys update?
Need help deciding which phone
#2

Hi @coreyk,

This is good info to have, and related to our Help article:

To minimize some of the guesswork, could you update your article to describe the specific symptoms of “WiFi issues” that seem to be specific to using WEP security?


#3

i can do that.


#4

It also turns out that the vastly superior security protocol known as WPA2-PSK [AES];

also the Wep security encryption protocol is also not only particularly bad security wise but also one cannot even get better than typical 802.11g wireless router maximum data speeds of only 54Mbps rather than at least 802.11n wireless router maximum data speeds of about 450Mbps; the 802.11ac wireless routers maximum data speeds top out on top performing routers at about 1,300Mbps if one is lucky enough to have Verizon Gigabit connection for example in comparison.


#5

Here is a visual summary
image


#6

Hmmmm…this almost seems related to the issue my wife & I are having with our Motorolas. In our case, it’s not WEP related. We have Google Fiber. The router defaults to WPA2 only. A few days ago (end of March 2018), an update installed on both our phones. (G4 and G5SPlus). Immediately after the update, neither of our phones will stay connected to our home WiFi. It connects for awhile, then disconnects for a short period, then reconnects, then disconnects–bouncing on and off.

The Republic Help article and this thread suggest the issue is about using WEP, but we are not and were not using WEP. We were using WPA2. Per the help article, I’ve turned on “legacy WPA/WPA2” mode in my Google router to see if this temporarily makes our lives better. However, we don’t want to use the insecure WPA protocol and nobody should be using WEP in 2018.

We are keeping an eye on this thread and hoping for an update for our phones to resolve this issue. I am more of a “don’t fix what ain’t broke” kind of guy, but these updates pester you–basically forcing you to install…and then you regret it. :disappointed_relieved:


#7

Hi @Troywolf,

What’s the build number on the G4?


#8

Build number: NPJS25.93-14.7-5


#9

Thanks @Troywolf.

You’re in an interesting position as a customer of Google Fiber, using a Google router and a Google (Android) build. Would you consider opening a ticket with Google Fiber to see if they have any suggestions?


#10

@Troywolf,
What router are you using on your Google Fiber?


#11

Mine is the GFRG210 Network Box.
https://support.google.com/fiber/answer/4584585?hl=en&ref_topic=2667450


#12

I can and will, but the issue definitely hit immediately after the Android update. I’m not 100% positive, but over the weekend I think I had the same issue at a public WiFi spot I use regularly. I ended up turning off WiFi to have data access. So the issue may not just be with my home WiFi.


#13

Have you tried simply forgetting the saved network and then reconnecting to the network? This fixed some connection problems for me when going from Android 6 to Android 7 on a Nexus 6 phone.


#14

I want to say, “duh”, but I guess not everyone thinks to do that :wink: I make my living as a software developer, so I’m pretty handy with technology and networking. My computers–including my wife’s laptop–run Linux exclusively. So you could say I’m a bit of a geek!

Perhaps interesting, when I first noticed the issue, I did a hard restart on the G4 (held button until it power-cycled). When it came back up, it wanted me to enter my WiFi password. So some kind of a “reset” happened. But the issue did not go away.


#15

@troywolf, the issue I described is exclusively to networks that were using the well out of date WEP protocol. I would recommend you try the basic troubleshooting steps for just after a system update. They include clearing the system cache. Clearing the Cache – Republic Help

I know you said you were a bit of a tech geek and worked it software development, but I hope you can understand that the basics need to be covered. If that doesn’t work, have you had a chance to put in a ticket with Google Fiber?