Unable to send texts

Unable to send text messages on my work Wifi or Cell. When sending messages it says "Not sent. Tap to try again. Works perfectly fine 100% of the time when on my home WiFi network…

I have tried turning this connection off and on and I have also tried updating all of my apps via the play store. No change.

I have confirmed with my in house network team that there is no issue with their APs. 100+ other users in my office have zero issues with their Wifi connection. Only me and one other staff members have issues and we both use Republic Wireless.

This has been going on for months. Rebooting used to fix this issue but not 100% anymore. Today I had a family emergency and it took me almost 20 mins to reboot my phone twice and send a text reply because of this issue.

Also, while I am unable to send text messages I can use data services without issue. AKA at the same time my messages fail to send I have no problem playing a music video on Youtube. So why are data services working fine but texting is not?

Finally, telling people to reboot their phone every time this is a problem is a “band-aid”, not a solution. Please provide an actual permanent solution to this problem.

Here is a link to Troubleshooting Texting Issues – Republic Help
It appears to be in the new format, so you may want to go through the Troubleshooting Tips section

Assuming that after going through the above, you are still having a failure, I would suggest you Open a Ticket, once you have the ticket number have your co-worker repeat your actions and then cross reference your Ticket when he submits his own

1 Like

Hi @fcodym,

It’s been a little more than week since we heard from you about your texting issues, and I was wondering if you’ve had any success solving the issue?

Here’s what I notice about what you wrote.

  1. You don’t have the problem at home. This would suggest it’s not something wrong with the phone, but something different about the work Wi-Fi network.
  2. Another RW member has the same problem at work. Does that member have the problem at home?
  3. The Wi-Fi data works for other purposes on the work network. That can mean that the network has certain features locked down. Sometimes Wi-Fi networks are set up only to allow web surfing.
  4. Rebooting the phone solves the problem. This could mean that the phone is actually sending the text message over cell, before the Wi-Fi connection is re-established.

Are you receiving text messages at work on Wi-Fi?
Are you unable to send any and all text messages, or only some?
When you’re connected to the Wi-Fi network at work, touch the top of the screen and drag down. Can you tell us what the Republic Wireless connections status notification says?

southpaw

Been having some success by just turning off WiFi at work to send texts at work, then turning it back on when the message says sent. Answers to your questions below.

  1. I have had zero issue form my home WiFi. I spoke to the network staff here and they have no clue. At any point in time there are about 1000 Cellphones connected to the WiFi network and they are not sure why mine and my co-workers phone get intermittent connections. They are going to look at the AP near our office.
  2. The co-worker also only has issue here at work
  3. Network guys says they allow both. Also mentioned that if they did only allow certain traffic it would be all or nothing so the fact that text sometimes work and sometimes don’t mean they are not blocking me.
  4. This is still the best fix if both cell and wifi does not work.

Text over wifi sometimes come in huge wave so no I don’;t think receiving text works all the time either.

When text fail to send they fail for all receivers. But sometimes they work, often the best solution for me is to turn it on cell and take a walk outside.

Connection status says: Republic Wireless On WiFI Connected to Guestnet

Thanks for following up with me on this.

Is there any chance that the text messages you are not able to send are MMS, and those you can send are SMS? MMS includes:

  • text messages with attachments (like pictures or video)
  • group texts
  • very long text messages

MMS requires an MQTT connection, which may be something specific your work admins have blocked.

If your IT team is amenable, @jben has created an excellent resource for understanding which ports our service requires. That information is available by unfolding the “details” section in Router Tweaks - Keep WiFi 1st - a Community Guide

1 Like

@fcodym Were you still looking for help with this issue?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer