Uni upgraded wifi to TLS 1.1 - now cannot connect

Hi all, my university upgraded their wifi security and now I cannot connect. They told me, simply, “that my phone is too old to use their wifi.” Since I only have 1gb a month, I really need to be able to use their wifi.

Would it help to force upgrade my MotoG4 to Oreo? Does anyone have any advice? I’m too broke to get a new phone and too broke to upgrade my data plan. Thanks!

What phone do you have?

What plan are you on?

Does your plan include data, or just talk & text?


Issue Description

That model according to Moto’s software update site…doe snot have Oreo.
https://support.motorola.com/us/en/softwareupgrade

moto g4

“This device will remain on Android 7 (Nougat)”

If you “force” install, or flash a rom not meant for that phone, it is not supported on Republic and the phone and app will not function with Republic.

Anyway, TLS should not have anything to do with that phone being able to connect to wifi.

What error are you getting trying to connect?
Have u tried Forgetting the network in the settings and connect again?

Not correct. Many corporate/education networks use EAP/TLS or PEAP for authentication. That being said TLS 1.0 really should have been turned off in 2016 and as far as I know there’s nothing that keeps Nougat from connecting to TLS 1.1 networks as the certificates necessary to do so are built in to even Nougat.

@banannah84 That being said, I think that what you’re being told is incorrect. Can you tell us exactly what’s happening when you try to connect?

3 Likes

@banannah84 Are you still stuck with this?

Hi Louisdi,
Thank you for following up! PEAP rings a bell. That’s what I have to select when trying to log into my univeristy’s WiFi. There’s no error message or anything but it simply doesn’t fully connect. I sat with IT for an hour. They ran a test which involved connecting to another server and I think what that did was confirm that my phone was not able to connect to TLS 1.1. I wonder if you have some advice for me regarding some “terms” to use if I go back to my university’s IT dept and ask for a manager. I’ll certainly show them this message.

Hi @banannah84,

Are you at the university this summer? Could you share a screenshot of the problematic login?

Hi @banannah84,

Here’s why I was asking about the problematic login. (Sorry, I’ve been out of the office a while and couldn’t check these details.)

At our office we often have people get stumped by signing into our secure network. The thing that ends up throwing everyone off is the “CA Certificate” option. It needs to be set to “Do not validate” on our network, and it’s something everyone seems to overlook.

Any chance that’s what’s going on for you?

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer