Unlocked phone? I bought my phone from republic and I want to put another's company sim card


#1

I bought a Motorola g4 from republic wireless. Now that I don’t have any plan, I bought a sim card with 10 mg from straight talk. It comes with three sim cards, one compatible with At&t, other compatible with T-Mobile and another with Verizon.
None of them are recognized by my phone. Customer Service from straight talk says I have to request republic to unlock my phone but there is no customer service number.
I need a solution, because I paid 45 dollars for this straight talk sim card :frowning:
Please, I appreciate your help.
Thank.you!


Republic Wireless refusing to Port my phone to Tello
#2

it is already unlocked
all newer 3.0 phones are unlocked

now then did you put it in the sim slot with the gold down and not the micro sd card spot
also it uses the mid side, not the nano or reg size sim,
with the phone setting on the screen and the slots to the left, top of the phone away from you the sim card is the second spot down or towards you…

https://motorola-mobility-en-in.custhelp.com/app/answers/prod_answer_detail/a_id/110813/p/30,6720,9687


#3

To contact Republic Wireless you just have to open a service ticket or chat session. You can do either in the Help Center.


#4

We only sell factory unlocked phones. These phones are incapable of being subsidy locked. It sounds like Straight Talk’s support is giving a fast answer. I would let them know that the phone is a factory unlocked version. Ask if they support factory unlocked versions.


#5

they do, support factory unlocked,
the OP is having problems with the phone recognizing the sims from the BYOP sim kit,
once the right size sim is installed in the correct socket. and the instructions are followed for activation it should work.

and yes it is a case of ST giving the fast one…


#6

@seanr seanr,
Are you aware of the issue happening I mention below? While the phones aren’t locked it looks like a RW CDMA SIM card might prevent another provider’s SIM from being recognized. Thankfully I didn’t get as far as having to do a factory reset. That may have worked? Before doing a reset I’d be wanting a couple of SIM cards from RW in attempt to fix the issue.
.

mariar.shfzwa,

You do state it is no longer active on RW. and my experience may not happen once RW SIMa are deactivated.

It’s possible you were on Sprint CDMA network and are encountering the same issue as I had. Support didn’t suggest my solution nor did they give me indication it was a problem they were aware of.

Below is from a RW Support ticket opened several weeks ago.

G4 from RW currently activated on RW’s CDMA will not recognize GSM SIM card or allow access to “Cellular network settings.” The GSM SIM is from another provider and my intention was to swap to a better phone temporarily since the other has a cracked screen.

Removed RW SIM inserted is active GSM SIM from another provider, G4 didn’t see it, thought maybe if cell network settings changed like adding APN might work. All options greyed out and only showed CDMA type options greyed out too.

I was finally able to get the G4 to recognize another providers GSM SIM by Inserting an active RW GSM SIM. Reboot and the settings were no longer greyed out.

I then inserted the other GSM SIM and it worked.


One year of Free Unlimited Data, talk and text at Sprint
#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.