USB cable connection loose at phone G4

USB connection is perfect on my husband’s phone but when I try and hook a USB to my phone it doesn’t work

Check the phone’s connector for lint or other obstructions. If you find some, remove carefully to prevent damage to the internal pins. Small tweezers or canned air will work.

1 Like

I checked with a magnifying glass I could not see any type of obstruction.
The connection to the phone wobbles from left to right. I could not see any
damage either.

1 Like

If you haven’t yet:
-try another cable
-check to see if your case is preventing full insertion

Is this a new problem?

1 Like

Had to have mine replaced at local cell repair for about $50 several months ago

1 Like

I tried 3 different cables. I even tightened one cable and that didn’t
work. The case is not interfering with the cable.

Where? There’s nowhere to repair a RW phone that I know of. Did they
repair the phone or the cable?

What do you mean when you ask if this is a new problem?

there are some variations in the connections,
seen a number of the same model, same usb cable be snug in one loose another one, some have more wiggle room than others.

so does the phone charge when you plug the cable into the phone?

or are you talking about plugging it into a computer and it doses not show up.

Trying to understand if you’ve had success in the past.

The usb works fine when charging but wiggles a lot. It will not work when
using Android Auto due to this.

It will charge;however, when trying to use Android Auto, it will disconnect
when the phone is moved even slightly due to the wiggleness of the usb. I
have tried 3 different usb cords to no avail.

If Android Auto uses data connection via port you are aware that the USB mode must be changed from charging to data? It’s done by a swipe down to to see the notification/option to change.

If you’re doing that and no joy there’s a possibility to port has lost the data connection.

:flight_departure:

I had the same problem

What happens is the connector inside the phone comes loose or unsoldered.

The way to fix it is have a cell phone repair shop replace the connector in the phone.

It cost me about $50 to have that done.

Jim

The phone.

It’s a mechanical failure not an electrical.

Jim

1 Like

there is no Republic version of the Moto G4, all 3.0 phones are North American Factory unlocked phones
This is a basic hardware failure (one of the few thing a local Phone Repair shop can handle (Charge Port replacement, Battery changes, headphone jack/speaker replacement, Glass Replacement camera replacement can all be done by a local shop)
here a national chain https://www.cellphonerepair.com/
another option is to deal with Motorola directly https://mobilesupport.lenovo.com/us/en/products/cell-phones/android-series/moto-g-4th-gen?linkTrack=Homepage%3ABody_Search+Products

Thank you for this. It sounds plausible since the phone goes into charging
mode when I plug it in; however, when I swipe down I get nine options but
none are an option to change this. I did a search for on changing USB mode
to data this but nothing came up. I have high hopes that this will work.

Thanks for your update.

I personally don’t know how Android Auto works what the data interfaces are or what you are trying to connect to on the other end of the cable…Found some info and assume you’re trying to connect data cable to an auto device. https://support.google.com/androidauto/answer/6348190?hl=en&ref_topic=6347951

Does you husband’s phone work with your AA?

While my G4 is connected to a USB data source & charging, then swipe down, I’ll see USB charging and Tap for more options in a white band below the Quick Settings.

Have you connected your phone via USB to a computer to see if the options are available?

Are you certain the cords you tried are all data capable? Can your husband access his phone data via USB using the cable(s) on a computer.

One last long shot, start in Safe mode and check the USB options if you find that’s the issue…

If all that’s been eliminated you may have an internal data connection fail as previously suggested.

:flight_departure:

Thank you for trying. I do not get the options you are speaking of. Yes,
my husband’s phone works fine with AA. I guess I will get in touch with
Motorola since they sent me this phone rather than RW. Thanks again.

thank you for your help. The repair company had no idea why my phone does
this. lol. I contacted Motorola for a replacement phone (3 times btw).
ugh

Message an
Expert customer