USB connections suddenly problematic

What phone do you have? Motorola G7 Play

What plan are you on? basic

Does your plan include data, or just talk & text? data


Issue Description

After working for many months, all of a sudden I cannot transfer USB data and the lighting bolt does not show on the battery icon. The battery does charge though. The only way i know is the battery percentage increases when I plug in the cable. The USB options that used to show up are not present under notifications. HELP

  • Have you tried a different cable? 1st guess is bad cable, 2nd guess would be bad connection on the phones motherboard.
    • Please post back with results

I have tried new cables, I have tried it on another computer, I have power cycled all computers and the android several times.

To me it sounds like you have beat me to all the easy fixes … so that leaves one common thing left … probably a hardware failure of the phone itself.

Hi @tinkyr,

Welcome to our Member Community.

Another member recently wrote with the same issue, but has not returned to continue troubleshooting with us. One of our developers had some suggestions for him, and I was wondering if you’d give her suggestions a try. You can find them here:

Check for debris in the port.

@tinkyr Did any of these suggestions end up working for you?

Hello

Sorry I did not answer this earlier. The issue was a lot a very small woodchips inside the connector. I used a dental pick and pried them all out and now it works fine.

Thanks

dave

Fantastic! Glad you were able to get it resolved and in the future keep your phone away from woodchucks!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer