Using a flash drive with the phone

#1

What phone do you have?
What plan are you on?
Does your plan include data, or just talk & text?


Issue Description

I have a moto G3 phone, running Republic 2.0. I just purchased a combo sandisk mini usb and usb 3.0 flash drive. I used one of the commercially available OTG checkers to see if my phone supported OTG. The answer was yes. I just received the drive. I plugged in the mini usb but the drive does not show up as an option to download picture files (which is why I bought it). I checked another site which said the phonee has to be rooted. Is that what I have to do and can I do that with this phone on Republic 2.0? Thanks

#2

Moto G3. REPUBLIC 2.0.

#3

My first guess would be the drive format, I believe the Moto G3rd like to have fat32 as it;s format

1 Like
#4

It is supposed to work on fat 32!, ntsf or ext3nded fat 32.

#5

Also, you might have missed this. One web site said the phone has to be rooted. Can I root the phone on Republic’s system? If so, how?

#6

Another piece of information. Under system/ storage, the usb device is showing up with the correct amount of memory showing. How do I access this drive. It does not show as a choice when I want to move pictures.

#7

this maybe I going by memory and I don’t currently have one to test on

Officaly Republic would not stop one from Rooting but they do not support phones that have been Rooted,
that said I’m not aware of anyone being successfully getting a root on a Republic phone with an OS pass 4.4.2 (the boot loader is locked and Motorola/Lenovo has not release this lock an any of the custom ROM phones

Moto Phones do not include a File Manager (There are many that can be download from the Google Play store (I like the Total Commander)

1 Like
#8

Perhaps you can solve a different problem for me; the real reason for trying the usb flash drive. After working fine for months, I can no longer transfer pictures to my sd card. There is plenty of space; 20 GB avail@ble. Some pictures transfer but most get lost in the ether. What shows on the sd card are blank spots where the pictures shoukd be. I thought maybe there is a max # of files per album, so I tried creating several different albums. That seemed to work until I tried sending a bunch of pictures to a new album on the sd card. I lost them all. Any ideas? I

#9

The only thing I can think of is that the SD card may be starting to fail,
I would take it out and see if a different device can read it [computers trend to do a better job than phones I’ve had multiple SD cards that where correctly formated yet still could only be read by computer [these have all failed since then]

1 Like
closed #10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer