Using too much cell data

I have a Moto G Power running android 11.
I have the My Choice Plan + 1GB data.
My problem is that when my Wi-Fi signal is cut off from my home router because my ISP goes down - AND I’M NOT AWARE OF IT - my phone switches automatically to CELL Data and I quickly eat into my 1GB before I know it.
Is there something I can do to stop this from happening?
I don’t know if this is a phone issue, or a Republic one.
This month I have had to buy an additional GB of data with three weeks remaining, and it was eaten up in just a few days over the same issue.
I now have ONLY 25MB available and I’m NOT going to buy a 2nd GB.
I realize that I have an issue with my ISP interrupting my service which triggers the problem I described above, but stopping the automatic switchover to data usage when that happens would preserve my data,

2 Likes

Hello!

Here’s a potential solution. Also, RW will send you a notification indicating that you’ve lost your wifi connection. If you’re not receiving that, check your settings.

1 Like

In addition to the excellent advice by @ceedee, you may also be able to find an app in the play store that can be set to play notification tone when you switch between WiFi and cell. I’ve never used it, and my posting it here is not meant as an endorsement, but I saw this one as an example: https://play.google.com/store/apps/details?id=com.ekstrlabs.netify&hl=en_US&gl=US

I’ve added 1 GB of data to your phone at no charge so you can have a little more breathing room to get this figured out.

4 Likes

Thank you southpaw for the 1GB of data.
Per ceedee’s instruction I enabled Data Freeze on the Republic app.
I then disconnected from the internet by unplugging my Modem/Router and saw the “key” icon at the top of my screen indicating that I had no Wi-Fi signal.
With the Data Freeze enabled, I would assume that none of the apps that I regularly use (these are the ones that caused the excessive data use in the first place) would work since, as I understand, it takes either Wi-Fi or cell data to access them.
However, I tried three different apps and all three were working?? AND, they were using data, because the 1GB you gave me dropped to 1002MB.
So, it looks like the Data Freeze (that was enabled) isn’t doing what it is supposed to do.
I’m confused??? Please Help !!

This is a good point, @leep.ncy62c, and I’m glad you had a change to give it a test.
Newer Android versions have restricted how much control we can place over other apps’ access to cellular data, and we are starting to see other apps succeed at using data when Data Freeze is enabled. :disappointed:

The benefit of using Data Freeze (before these recent Android changes) has been that it allows the Republic app to continue to use cell data (we don’t count that use against what you purchase) so that there is no interference to calls and text messages while other apps are restricted from using data.

The other two options are to disable cellular data, as you suggested, or put the phone in airplane mode with WiFi re-enabled. In either case, if your WiFi is disconnected, the Republic app (like the rest of the apps) will not have access to data, so you may miss text messages and voicemail notifications and you may be unable to place outbound calls. Inbound calls would still reach you with cellular data disabled, however, they would not reach you in airplane mode.

Have you discussed this with your ISP? I’m wondering if it’s something going on solely on your network - with the possibility of a fix with a replacement router or modem, or if it’s truly something going on that’s affecting all the ISP’s subscribers in your area.

I’m kind of arguing with myself over this one… the way the phone is behaving, your WiFi connection drops and the phone starts using cell - suggests that it’s your home network that’s dropping the connection, not a simple loss of service from the ISP. Here’s why (and @jben or @rolandh or @louisdi or someone please tell me if I’m overlooking something here):
When the phone (any Android phone, not just RW phones) is on a WiFi network it doesn’t use cell data.
When the phone drops the WiFi connection, it starts using cell data.
But, if the phone maintains the WiFi connection - so it’s still connect to your network, but the network itself has no internet connectivity - the phone would keep “using WiFi” but with no functionality. But it wouldn’t use cell data, because it is still successfully connect to a WiFi network.

What you’re describing:

would seem to fall in that third scenario - the phone remains connected to your home WiFi network but there’s no internet connection on that network.

But the behavior you’re describing - connecting to cell - suggests it’s actually your home WiFi signal that’s dropping.

Can you tell us what the phone’s status icons show when this loss of connectivity happens?

One other thought on the ‘Data Freeze’ portion of this problem … you wouldn’t be using a VPN … Why Doesn't Data Freeze Work After Using a VPN? – Republic Help

Would you be willing to identify the offending apps?

OK, I’m trying to keep up with all this, and I thank you all for your help and suggestions.
Here’s where I stand at the moment.
Regarding my ISP, I did contact them a few months ago about service being dropped, and the technician that came out suggested that my modem and router was outdated (or maybe it was just the router, I don’t remember). So, I purchased a Netgear modem/router, and, until very recently I have had no problems.
Regarding a VPN, I don’t use a VPN.
I’ve been digging around all day (with my old, non-technical brain) and here’s what I’ve come up with.
I’ve gone to settings/ Network & internet / Mobile network (Republic) / Mobile data, and turned OFF “Access data using mobile network”.
Then I’ve gone outside where there is no Wi-Fi signal, and tried to connect to the three apps I mentioned, AND also other things like browsers, CNN, etc.
None of them would work or connect which is what I wanted, since I only want them to connect using Wi-Fi.
I think this would “solve” my problem of switching to (and eating up) cell data when my Wi-Fi goes down for whatever reason.
I didn’t mention it before, but the problem I was having was at night when I was sleeping (or trying to sleep). I play half-hour talks or lectures on the apps which shut off when they end. I repeat them many times during the night to help me drift back to sleep.
Most nights there is no problem, since my Wi-Fi signal is working OK.
But, occasionally, when I get up I discover that I’ve used hundreds of MG because of the problem I’ve mentioned.
So, when I go to bed tonight, I’m going to do what I mentioned above and see what happens.
Is my thinking sound about this, and will it work based on your knowledge and expertise?
Thanks again for your help.

What you’ve done - disabling access to cellular data will prevent the lectures from eating up cellular data if your WiFi signal is lost.

However, with your phone set like that, if your WiFi signal is lost, you would not be able to send or receive text messages and may not be able to make calls. If that’s not a problem for you overnight, and if you will remember to re-enable data before you leave the house, then it’s a workable solution.

Are these lectures that you listen to something you could download when on WiFi and save to play from the phone (rather than streaming) overnight?

No, that is not a problem overnight for me.
I did notice that my outgoing text messages (and I presume incoming ones) did NOT send as long as my phone was set like that.
So, I will follow your advice and re-enable data before I leave the house.
Am I correct though, that as long as I’m home near a working Wi-Fi, I don’t have to re-enable data for talk and text to work?

I’m not sure I know how to download and play them. I’ve never tried it.
I guess I was concerned that something downloaded would stay on my hard drive and take up storage space.
Anyway, as long as what I did last night is a workable solution, I’m fine with streaming.

1 Like

Opinion: Routers “fail” more often than ISPs.
Consider a 5-dollar lamp timer.
Use it to power-cycle your router daily, like at 2 AM.
Lots of issues will go away.

Or, get one of the newer TP-Link routers, say at Costco (great returns policy)
that have a built-in menu option to schedule re-boots of the router.

6 Likes

I just buy more data it’s not that expensive. I use a bunch mostly because there is no wifi where I work it’s a secure government site. I go surf mad at lunch catching up on the world around me

2 Likes

I have same phone, same Issue, and others, My fix was a new Comcast gateway, manually split the 2.4 GHz & 5GHz wifi signal (mostly for other reasons) sign into (one side) of your gateway, start with the 5GHz, use phone as normal. also; (refreshing the Republic Wireless activation)-How to Refresh the Republic Wireless Activation – Republic Help .
also; How to Clear the Cache on the Phone Application – Republic Help
Restart phone at least 1 time a week. If you have week signal on 5GHz, also sign into the 2.4 GHz side of gateway, check for week signal?
After this work you can; How to Disable Handover to Prevent a Call from Switching from WiFi to Cellular on Specific Networks – Republic Help. You might need to make sure you have good gateway in-home placement and check for things that could interfere with your Wi-Fi signal; 10 Things in Your Home that Interfere with and Block Wi-Fi Signals Lets all remember a few things:
Republic Wireless is a VOIP phone. (voice over Internet Protocol) your ISP
(internet service provider) treats RW as such. Covid and the lockdown forced everyone home. made most of the Network’s go past capacity. ISP’s “drop” VOIP Phones like MagicJack and RW “first”, saving data/bandwidth for other services… I do these maintenance items whenever I start having issues or every couple months as a refresh… It works for me, But I do not know what or which combo of these helps the most…

I had this same problem with my daughter. I had her turn on airplane mode when she is in the house. Seemed to solve it for me.

1 Like

@garyb.tiqdmy, this is interesting. I started reading this thread because of frustration with data being used, similar to but not as bad as @leep.ncy62c. We have started having troubles with our internet going down at home, about once a day, since mid-July. Before that, we had no problems. Is it the WiFi router that you recommend rebooting daily? Sometimes we also have to reboot the cable modem.

I would recommend calling your internet provider and troubleshooting the issue. It could be as simple as poor wiring that needs to be replaced. Your internet service provider should be able to run tests to determine the problem.

6 Likes

An occasional reboot of your network equipment is recommended by many, however, if you have to resort to it daily, then something is usually amiss. This can be the ISP and the course of action that @cbwahlstrom recommended is best, it can also be something as simple as changing the channel your router is using. Often a neighbor has added/changed something and are interfering with your router.
Most of this is covered in Router Tweaks - Keep WiFi 1st - a Community Guide

2 Likes

The router can be set to reboot daily or one a week, whatever you choose in the menus.

I haven’t rebooted cable modem in over 90 days.
TP-Link routers that I have used that have this nice feature (scheduled reboots) are: Archer C4000 and Archer AX21

More info is at: https://www.tp-link.com/us/support/faq/2094/

Thank you @cbwahlstrom . It makes sense to be sure all the connections are good. I’ll call to schedule a visit.

1 Like

I work on a secure government site so there is no wifi available hence burning up the data. I have a lot of down time waiting for escorts so I can even go in the building and work

Message an
Expert customer