Using WIDEX BEYOND to connect with hearing aids



I have new hearing aids which can be controlled by a smart phone to narrow the hearing field, increase/decrease volume, etc. It connects using Bluetooth. However, my Moto X would not pair via Bluetooth, so I bought a new Pixel 2. Now I discover it ALSO fails to find my hearing aids for Bluetooth pairing.

I begin to thinnk there is something in the Republic Wireless setup which disables this connection. Can you verify that for me? (If so, I will change providers, probably to Google Project Fi)


Try turning off WiFi in your phone settings and see if the phone pairs with your hearing aids with WiFi turned off.


Hi @raymondh.76dxm6,

I don’t believe there would be anything specific to Republic’s setup interfering with the Bluetooth connection between the referenced app and your hearing aids. The Pixel 2 specifically is North American factory unlocked. Republic in no way modifies the operating system. You might try temporarily removing the Republic app to see if that’s the root of the interference. You won’t be able to use the phone as a phone while testing this.


Hi @raymondh.76dxm6,

I don’t know of anything in the RW app that would disable this functionality. Since you have the Pixel, it’s something you could easily test. Just remove the Republic Wireless SIM and uninstall the Republic Wireless app. At that point, there’s nothing about the “Republic Wireless setup” that would remain. Does the phone then pair with the hearing aids? Let us know.

Once you’ve confirmed it’s not the RW app causing the conflict, I’m sure our Community members will be glad to troubleshoot with you and find a solution. Thanks for giving us the opportunity to do so.


From the Google Play description

WIDEX BEYOND and the WIDEX BEYOND APP are compatible with the following devices:
• Samsung Galaxy® S7
• Samsung Galaxy® S7 Edge
• Samsung Galaxy® S6
• Samsung Galaxy® S6 Edge
• Samsung Galaxy® Note 4
• Samsung Galaxy® Note 5
Widex is continually listing more compatible Android devices.

  • I have used the Siemens app with HA’s with no problems pairing with any of the heritage Moto’s nor the current Moto X Pure
  • You may want to consult either your HA consultant or Widex


Looks like @jben has the answer, but I’ll throw in that I use a Widex COM-DEX with my Widex hearing aids. The COM-DEX seems to work with most any bluetooth capable phone. I’m glad you started this thread. I’m due for some new hearing aids myself, and was wondering about the bluetooth ready aids.


I have been using the Rexton Legato (from Costco) for a couple years now. I chose it be cause it used the rechargeable LI batteries , but because it needs recharged after approx 12 hours have reverted to using regular batteries. I have been very happy with and have it programmed for 5 presets. The app provides very good directional mic tuning but it times out after 45 mins and reverts to 360. I believe they can provide a setting that allows directional and not time it out.


Thanks - when I followed your suggested path, I was able to pair the hearing aids with Bluetooth. However, then I re-loaded the SIM, and am no longer able to pair. Maybe something about the home-away arrangement is interfering.


I may be dealing with a Bluetooth problem, rather than a phone problem. Even though the screen says the hearing aids are “paired”, another screen says Bluetooth is “not connected”. Going back to the screen where the HA’s are “paired”, there’s a “+” for “Pair new device”; selecting that, I cannot get the Bose color speaker to appear - it’s inches from the phone, and does show signs of life.
I have a call in to my local expert - my son.


Typically, for pairing to occur, bluetooth devices need to be in “pairing” mode, Typically you have to hold down a bluetooth button until lights flash or something like that. Here is a sheet on pairing your hearing aids with an iPhone. Maybe something in this will help:


Here is a video tutorial on pairing the Widex Beyond with an Android phone:


Thanks - I did see those pages, and they did work, once. But keep slipping away.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.