Very slow to respond


#1

I first sent an email/opened a help ticket last evening. I’ve received 2 responses today, neither of which helped at all. Anyone know why they’re so slow to respond today?


It's my phone crash related to the systems crash yesterday?
#2

It’s possible they have a higher than normal ticket volume because of the recent outage. They normally try to give responses within 12 hours or so. If the responses that you have received have not helped, please reply back to the ticket letting them know (that it hasnt helped).


#3

You can also let us know what you’ve got going on here so that we can try and help with the issue you’re having.


#4

My daughter’s phone abruptly crashed yesterday. It was charged at 50%. Since then it won’t charge or reboot, and I’ve tried everything that was suggested. She leaves on a trip next week which is why time is of the essence. Thank you!


#5

What phone is it? If iit is an older phone, I would personally lean towards suggesting its time to replace it.

Republic is overwhelmed with tickets, no doubt due to the recent severe outage, so it will take excessive time for them to help you. Their shipping center also is behind due to the recent holiday.


#6

Her phone is about 2 years old, so yes it needs to be replaced. I’m hoping republic will replace it.


#7

Republic doesn’t replace phones. The phones they sell have a 1yr warranty with the manufacture, which is the same with any other of the carriers out there. With the exception of Insurance plans that they charge you extra per month for, but, unfortunately, Republic, doe snot offer that kind of service.

You can purchase a new phone on the Republic website, but it maybe faster to buy a compatible phones from a place like Amazon to get faster shipping if time is really important.

Have you tried holding the power button down for at least 30 secs. that should force a reboot.
Depending on the phoen model, holding the pwer and Vol Down or Vol up at the same time can force a reboot and get ito the recovery menu where u can do a factory reset.
If both those methods fail, and it is not a phone that u can just pull the battery out of, it may be hardware failure.


#8

Is it possible that my daughter’s phone crash (totally dead, won’t charge, won’t reboot) is related the the system failure at republic yesterday? It was working perfectly before. Seems like a huge coincidence.


#9

It is possible that your daughter, like others I know, did some rather extreme things to their phone trying to get calling and messaging to work during the outage.

When you first plug the phone in does the charge level appear for a few seconds?


#10

No, she didn’t do anything but try to charge and reboot, as per instruction.


#11

And no, nothing appears on the screen.


#12

This problem was not caused by the outage. Most of the time when a phone will not charge either the charger or the charger’s cable has failed. Have you tried a different charger? The phone is warranted by Motorola for one year… Here is a link to their repair center.

https://motorola-global-portal.custhelp.com/app/mcp/service/


#13

I checked the cord and the charger. It works perfectly on my phone, which is the same model as my daughter’s. Thank you.


#14

Since you can’t turn it on and you don’t see the charge level when you first plug the charger in there are a couple of things you can try before arranging for a repair or replacement:

  1. After the phone has been plugged in for a few hours press and hold the power button for two minutes. If there is a charge that is not being displayed that can force the phone to boot up.

  2. Inspect the charging port for pocket lint. Lint can accumulate there preventing the charger cord from making a good connection.


#15

I already did the 2 things you suggested. Numerous times. But thank you!


#16

Since the phone is about 2 years old it is no longer under warranty. Sometimes RW has “B-Stock” phones available at a significant discount. Usually these are phones that have been returned to RW during the initial return period and can no longer be sold as new. It might be worth your time to ask RW support if they have any.


#17

Thank you for your help!


#18

2x with my old Samsung Galaxy S3 with int he first year. Where i just plugged in it to charge and poof, it went dead, never to turn back on again. I had to RMA it. SOme sort of electrical short or shock to the port maybe?


#19

Annoying!