Voice Mail Box Not showing voice mails

My voice mail box is not showing voice mails. I have to retrieve voice mails by calling voice mail and retrieving. Have tried restarting phone, uninstall and reinstall Republic app and changing from wifi to cell. Still having problem.

3 Likes

Hello @williamm.h9j5nj, :slight_smile:

Please let us know if this Republic article helps:

No. Did my the uninstall and update. Not working.

2 Likes

Please look at the instruction again. There’s nothing mentioning having to uninstalling anything.

  • Open the Phone app and tap the three-dot menu icon
  • Tap Settings
  • Tap Voicemail
  • Tap Visual Voicemail
  • Tap the Visual Voicemail toggle to disable Visual Voicemail and confirm by tapping turn off
  • Tap the same toggle to turn it back on
  • Tap the back button twice to exit the Phone app’s settings menu
  • Tap the back button twice to exit the Phone’s settings menu.

I am seeing same behavior…appears to be another updates to Phone by Google app that is causing the issue. When I updated my Phone by Google app…it does show the voicemail tab…but all the saved voicemails disappear.

Uninstalling updates to the Phone app appears to be temporary workaround as in the past.

1 Like

Yes I did that and it the voice mail worked once. But then it failed again… Republic has an open ticket now but I’m at the point of dropping them Too many problems.

The instructions call for uninstalling and then re installing updates… I am recommending that you uninstall and leave it uninstalled. With this… I am getting stable behavior. If you are experiencing the same issue that I am experiencing then that is a Google issue…unfortunately there is nothing RW can do about it.

As a reference…if you are seeing this …then that’s the latest app and it has the issue as shown by empty voicemail message.

1 Like

@amitl what is the Phone app version number where the app is failing to load voicemail?
Please also let me know the app version for the Carrier Services app.

Phone app version 70.05.40140880
Carrier Services app version 67.0.383886470-carrierservices-V67_RC00

After my last round of uninstall and reinstall of the Phone app…the voicemail tab has vanished. Don’t know if the app is actively being updated…but I no longer see the screenshot I sent earlier…there is no voicemail tab at the bottom.
Visual Voicemail is turned on in the settings.

Just being turned on isn’t enough. After an update you’d want to toggle it off and back on as a troubleshooting step if you’re having trouble.

And if saved voicemail fails to load after that, you’d want to refresh the republic activation as a next step.

Yes. I am seeing this, although I have always seen this even when the voice mail tab was working. I will.unistall the Google phone app and not update as you suggest. Thanks much.

I tried both those steps…but saved voicemail is still not showing.

Uninstalling the Phone app updates…restores the saved voicemail without any additional steps.

1 Like

Yep. Uninstalled the Google phone app and the activating visual.voicemail screen is gone and voicemails are there. What a marathon. Thanks again.

3 Likes

Good to hear you are back to normal functionality.

You may want to double check that you don’t have Auto Update enabled in your Google Play Store.

Yep. Just disabled auto update. Thanks again.

1 Like

Screen has returned

Sorry to hear that, my Phone appears to continue to work normally after uninstalling the updates.

You may want to try the two steps mentioned above.

  1. Toggle Visual Voicemail OFF and then ON in the Settings

  2. And if saved voicemail fails to load after that, you’d want to refresh the republic activation as a next step.

If those don’t help maybe continue to work with Republic Help in your ticket.

Message an
Expert customer