Voicemail issues on Moto X 2nd gen

On my Moto X 2nd gen, if I check my voicemail by holding down 1, which calls voicemail, I get some weird results. I am wondering if this is a bug or if it happens to anyone else. I haven’t seen anyone else report this same problem, but maybe I’m missing something.

The automated voice asks me for my password, regardless of whether or not the ‘password’ option is checked in the RW app. Then, it seems that typing in the correct password simply ends the call. How bizarre. That happen to anyone else? I checked the settings in the RW app and they seem correct.

Thanks!

Voice Mail password is now required for call in

Change to Dial-in Access to Voicemail

Voicemail

not sure why it hangs up on you when you enter the password (I always check voicemail via visual voicemail in the the call log)

after checking setting and it still hangs up on you I would create a help ticket

Hi @melaniek.sgx6nz,

@drm186 has you covered regarding the change to dial in voicemail. I also agree with him in that I find viewing voicemail locally on the phone to be preferable to dialing in. It’s one of the great things about having a smartphone.

Regarding the hangup phenomenon, if it continues after setting up a password, I’ve seen reports from other members that pausing for about a second between numbers when dialing in seems to help. The other remedy I’ve seen mentioned is to dial in on cell rather than WiFi.

Yeah, I normally prefer viewing voicemail locally too, but I’ve got other screen issues that make it appealing to be able to call in also (I actually can’t delete voicemails without calling in). It does seem to work every once in a while.

I tried your pausing between numbers idea and that seems to work. Maybe that is why it does work sometimes. Thanks!

I also opened a help ticket (before your response) to see if this is a known issue or not.

You’re most welcome! Please let us know if you get any more helpful information as the result of your help ticket. Also if you wouldn’t mind trying on cell rather than WiFi, do you still need to pause between numbers? If not, I have another idea.

Regarding the screen issues, is it physical damage or something else we might be able to help with?

Yup, you’re right, that works too. Guess I should have tried that but I didn’t see why it would make a difference once there is a call in progress.

Screen issues are under control, but if you have any other suggested workarounds, I’d be happy to hear em. Thanks

Problems with screen turning off during call

I see you’re already getting help regarding the screen hardware issues and don’t really have any further insight to add to that.

I think I can provide a bit more insight regarding the issue with calling into voicemail. Touchtones (DTMF to us geeks) don’t always register when using Voice over Internet Protocol (VoIP). VoIP is the technology that powers Republic’s WiFi calling. Generally, Republic does a good job with this but the phenomenon occurs with some frequency due to the nature of the technology. I’m a bit of a VoIP geek.

There are some settings on your Moto X2 that mimic the delay between sending touchtones, I initially suggested by waiting a second or so between numbers. They are available by:

  1. Open the Phone app.
  2. Tap three dots upper right.
  3. Tap Settings.
  4. Tap Calls.
  5. Tap DTMF tones.
  6. Tap Long.

The above may improve the experience when dialing in. One final suggestion that sometimes helps also is muting the microphone while sending touchtones to Republic’s voicemail server. The fallback is simply to use cell, if necessary. If there is need to do so, Republic won’t object to your not being WiFi first in this instance.

Message an
Expert customer