Voicemail - no icon notifying me of voicemail even tho there are new msgs, AND disconnected from VM regularly

I have a Samsung Galaxy J7
Plan - My Choice + 1 GB

My problem is two-fold:

  1. Sometimes I “discover” I have voicemails by randomly dialing the voicemail number. I don’t receive the voicmail icon at the top of the screen. This just happened today, I had 6 voicemails going back 2 weeks that I didn’t know about. (Not great for business, eh?)
  2. Sometimes when I dial the voicemail number, it asks for my password, I enter it and then press #, And then I am immediately disconnected. This usually happens 2-4 times in a row. Sometimes I let it “rest” and dial back later and then finally get through.

Please, help. So frustrating. The only thing I can think to try is to restart the phone, which I have done but does NOT seem to help the problem.
BC

I experience this with my Samsung S7, especially having to enter my voice mail PIN several times. That seems to work better if I dwell on each PIN number a bit longer. The VM notifications were certainly more reliable on the Moto X (2nd Gen) I used to have.

@bobbiec1 Hello Bobbie, it’s been almost a week since you originally posted your question. Are you still having the VM notification issue?

Hey sorry for my delay. But yes, still having this as an issue. A friend just called, I denied the call, it went to VM, she left a VM, and I got no notification at the top of my screen or in the pull down notifications. The only way I know I have a VM is to go to recent calls, and see it there. I’m not really happy with this problem! I’m afraid I will miss something important!

You may have inadvertently blocked or turned off the VM notifications, either in the settings for the VM, or in Android.

I do not have a Samsung phone but it should have notification settings you can use an select the phone app and see if notifications are enabled for that app. Scroll down on this article for some possible instructions.

Right you are, SpeedingCheetah! Thanks…

However, I can’t tell you which notification was disabled. When I got into my apps (from Settings, Notifications), there wasn’t “Phone” or “voicemail”. I decided to turn all apps on, regardless. Then went to Advanced Notifications, 3dots clicked “Show system apps” (where the phone app shows THREE TIMES, and voicemail not at all). I “Reset App preferences” which I assume took them all back to default.

Now I will need to 1-by-1 turn off pesky apps again, but this will be worth it to have my Voicemail notification back! Thanks for the hint/tips!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer