Voicemail Probelm - Incoming calls asked for password


#1

My Moto X died. I replaced the X with the G4 Plus. Everything seemed transfer over to the new phone without issue except for Voicemail functionality. When someone calls my phone and I’m unable to answer, the callers do not get my voicemail message or the ability to leave a message. They are asked for “the password” as if it was me calling from another phone.

How do I fix this?


#2

I think I figured out what is happening. When the Moto X died (did not die completely as I was still able to access the republic wireless app), I setup of the voicemail to forward to my work cell phone. Apparently that is still happening. I forgot to turn that off when I setup the new phone. I can’t find a way to turn off the voicemail forwarding on the new phone. The RW app shows it as being turned off.

Thoughts?


#3

You changed carrier when you went from the X to the G4+ … I assume the G4 has been Activated as an Upgrade and your phone number has transferred over (and has been working for a few days)

  • I would suggest you try forwarding your Voicemail on the new phone to the Work number
    • If it works then turn it off the Voicemail Forwarding in the RW app and see if you are then back to normal
  • Assuming that doesn’t fix the problem then open a Ticket with Republic Help

#4

Thanks for the response. I did not changer carrier, just changed phones on Republic wireless. I’ll try your suggestion and see if it works.

Thanks


#5

Your suggestion worked. Wish I had thought of it sooner.

Thanks


#6

Actually when a user goes to any of the new 3.0 plan/phones they will ‘probably’ be changing to the GSM Carrier (not Sprint). Some phones/people will be assigned phones on the CDMA Carrier (Sprint) but at this time that is not the norm. (seeRepublic Wireless 3.0 CDMA Update,for more details)


#7