Website Not Working Worth a Darn

I’m trying to create a followup to a closed request because of the additional problems that succeeded the original and painfully extended problems with the original request. The site would not permit creation of the followup but kept recycling me back to the page with the archived original request. So then, I tried opening a new request, but the system would not do it. I went to help, but it resolved to a page that would not permit any action. I went to Community and tried to get to Republic’s “open a ticket” from there, but no dice.

Most sites with problems display something to indicate that an issue is present, or they at least offer a phone number to call for customers to find out what is going on, how long it will last, etc., but, of course, no such luck here because of Republic’s fond desire, they say, not to have people listening to elevator music while waiting on hold. The more cynical side of me has to believe it is purely to do with the cheaper mode of doing all communication by email, with no phone service available at all, ever. Well, if this is how it is to be, the least Republic can do is to offer some sort of notification about malfunctions on its website, including the extent of disruptions and the predicted time to full functionality. Given that we cannot call, that seems the minimal customer-friendly thing to do.

Getting Help from Republic

known issue please reply to email or use chat like

@seanr Jan 31, 2017 11:10 PM

I did find an issue with the reply button in the help portal. I have sent this to the developers. Just reply over email for now. Thank you for bringing this to our attention.

@rickc.agx2ie

Republic Staff/Techs have been notified (and it fails for a couple of us) … you may be able to find the email from Republic and answer via email … post back if that works

  1. Someone else said to use Chrome or Firefox Private, but that should not be necessarily, given that Firefox regular has given me flawless service for years, including service on the Republic website. The problem is on the site, not with Firefox.

  2. “You may be able to find the email from Republic…”? How do I do that? Where do I go to “find” the email? Should it not be obvious?

Hey @rickc.agx2ie!

You should have received an email in your email associated with your Republic account. If your inbox has a search function, you should be able to find it by typing “republic”. Have a great evening!

mb2x

I replicated the failure using IE/FF/Chrome … the email from Republic should be in your normal email, but some have found them in their spam folder

Hi @rickc.agx2ie,

Thanks for bringing this to our attention (with a nudge from a couple of Ambassadors.)

We weren’t aware of an issue and we think we now have it working again. If you ever need to open a Help ticket and cannot use the web interface, please compose an E-mail to: help@republicwireless.com from your E-mail account associated with your RW phone account.

Hi @rickc.agx2ie,

I think you may find the issue with creating a follow-up to your ticket resolved. I had been sharing your experience, however, it’s now working for me. Please let us know.

Message an
Expert customer