WhatsApp and Huawei Ascend 5W (16GB)

#1

I have the new $49 phone that I like using android 6.0.1, marshmallow. I have a data plan.

WhatsApp worked on my older moto g. It works on the new phone too but an annoying popup about Google recorder appears. When I close it, it returns in 3 seconds. This blocks about 25% of the screen of a video call so I can’t see my granson. He’s a baby and that’s the purpose of the call.

Is anyone else having this problem? I found a little information about clearing the cache that may help and disabling the voice input for Google now.

I’m not sure of the downside of clearing the cache and I’m not sure I successfully disabled the microphone for Google now.

0 Likes

#2

I have a RW Huawei Ascend 5W; I use Whatsapp basically every day, and I haven’t gotten that issue…

0 Likes

#3

Hi @thomasw.xuldvnm,

I’m sorry to hear of the struggle. Essentially, WhatsApp and the Google app are competing for use of your phone’s microphone simultaneously. For reasons not entirely clear to me, this seems to affect the Ascend and other Huawei phones running EMUI (Huawei’s flavor of Android).

Clearing the cache is non-destructive and will have no negative impact on your phone. I’ve seen reports doing so temporarily solves the problem but eventually it seems to come back. Without knowing how you disabled microphone access for Google Now, it’s difficult at best to know whether you did so successfully. Perhaps, you’d be able to provide more detail on that?

Meanwhile, you might try the following:

  1. Open the Google app.
  2. Tap Menu (three stacked lines lower right).
  3. Tap Settings.
  4. Tap Voice.
  5. Tap “Ok Google” detection.
  6. Toggle Say “Ok Google” any time off.

I understand you’re probably not saying “Ok Google” when using WhatsApp but if that setting is on Google is attempting to use the microphone to listen just in case you should decide to do so.

0 Likes

#4

If a Floridian is not have in problems then maybe I have something on my
phone that you don’t. I use Google voice. My real phone number is on my
phone but I have a Google voice number that I give out freely.

Roland That is how I disabled the OK google. It’s too early for me to call
the west coast but maybe it’s fixed. I’ll clear the cache if that didn’t
fix it. I’m guessing if WhatsApp has has an update I will get it
automatically unless that’s not necessarily true.

Thank-you all for your help

1 Like

#5

Hi @thomasw.xuldvn,

Is this the error dialog you see on your phone other than mine says Republic Wireless and yours likely says WhatsApp:

I can trigger this at will simply by enabling the setting referenced in my previous reply. It’s a Google/Huawei issue not a WhatsApp or Republic Wireless issue.

0 Likes

#6

I turned off the mic for “ok google” as suggested and that solved the
problem.
thank-you

3 Likes

closed #7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes

Message an
Expert customer