When is Republic ever going to address Android Doze on their service?

Moto Z

My choice + 1 GB

So many phone calls never get through and go straight to voicemail when the Republic service on WIFI has gone to sleep. The whole point of your service was have phone service at home with WIFI. After years it still doesn’t work properly. I know about Macrodroid, that isn’t a solution. I know about battery optimization, that isn’t a solution. Why haven’t the engineers figured out how to fix this issue after all of this time?

1 Like

Hi @kishkan,

It’s an issue that is difficult to address - if there were one easy fix, it would have been deployed by now. If any app had the right to overrule Doze Mode, then every app would overrule Doze Mode, so Android makes it, by design, nearly impossible to overrule.

Even the user of the phone can’t configure the phone to avoid Doze Mode without issuing an ADB command that then has to be re-issued upon each reboot.

What would help, though, would be examples that elevate the issue and help us prioritize it. I’ve reviewed your Help Ticket history and I don’t see that you’ve opened a Help Ticket on the matter. While our technicians won’t be able to resolve the issue for you, it would be worthwhile and very helpful to have examples from members who are plagued by the issue.

Examples can be difficult to come by, because you have to know you’ve missed a call. But if you see voicemail for a call the phone never received (it must not appear in “missed calls”) then that would be a great example to provide to our technicians.
(Unfortunately, with recent updates to Android, we see a lot of reports of people saying their calls go straight to voicemail without ever ringing simply because they have enabled “Do not disturb” mode or have accidentally silenced their ringtone. It’s very important that there not be a “missed call” record logged for the call if we are to investigate it as a possible Doze Mode conflict.)

When we do have examples, we would need to pull call logs and your device logs fairly quickly (while relevant data is still available in those logs).

If you see this issue frequently and have examples to share, please open a ticket, with the following information:

  • The complete date and time (including timezone) of the call that went straight to voicemail
  • The caller’s phone number and intended recipient’s phone number (if you have multiple phones on your account).
  • Confirmation that you have submitted device logs: open your phone dialer as if you were going to make a call and dial * # * # 5647 # * # *
  • A request that your report be attached to master ticket 1829384 along with the device logs and call trace logs (the agent will have to pull these “trace” logs).

I do not make or receive more than a dozen calls per week… If I was a heavy phone user, I likely would be with a different provider. I get more spam calls than real…They nearly always end up in voicemail… Republic’s problem is my gain.

This issue has been ongoing since at least April 2020.

I submitted a ticket (1906081) on 5/23/2020 reporting this very issue. De Andria replied acknowledging that this was a known issue and that the Engineering Department was working on a solution to the issue. She said that my ticket was being attached to the master ticket addressing the issue.

I can confirm that the issue is ongoing. I can be sitting right next to the phone, it doesn’t ring and I suddenly have a voicemail alert. This has occurred many times over the last seven months.

I have also had a friend text me that he is on his way over. He shows up unexpectedly and 20 minutes later his “on the way” text message arrives.

This was never an issue prior to the 4/23/2020 update to the Republic App. Might I suggest, if you want to address the issue, that you roll back to the 3/2020 version of the App and start there. Whatever Engineering did in the April update caused this issue and it is still not being addressed

Thank you.

The issue was around WAY before that. The Tip and Trick around managing it ( Managing Doze Mode - (phone is on WiFi) calls via cell | calls go to voicemail | calls are missed (republicwireless.com)) is from June 2018 and that wasn’t written until months after the issue started, was experimented with, and a workaround was created. Republic updates had nothing at all to do with this issue, they started with the Google release of doze in August of 2017.


Extend Home is the perfect solution to Google’s Doze problem and it’s on sale!\


louisdi: Thank you for your reply to another issue.

As I stated both in my Ticket in May 2020, and this last post, the issue was not around in 2017. It was not happening in 2018 or 2019. It was not an issue in the first calendar quarter of this year. I first noticed it in April 2020 and reported it the following month. Republic support acknowledged the problem and said that Engineering was working on a solution for it.

The only reason I chimed in on the discussion is because I saw support personnel replying as if they’ve never heard of the problem before, asking for call logs to show a voicemail with no incoming call logged for it. I will endeavor to report those instances as they happen in the future.

Thanks again for your response to some other issue.

Hi @rick.d,

While you may not have experienced the issue prior to April, the issue has been around longer than that. I opened the master ticket in January, and had been seeing many examples, including my own experiences with the problem, before that.

Our engineering team needs examples, call logs, and device logs in order to determine the root cause and investigate any possible solutions. That agents are requesting those things does not mean they are unaware of the issue. They are following the instructions in the master ticket to provide the data our engineers need to make progress toward a solution.

This, however, would likely be a different issue.

1 Like

Hi Southpaw! Thanks for weighing in on this. For me, this is not a fatal issue as I am mostly retired and don’t have any need to immediately receive or respond to calls. As long as I eventually get the voicemail, I’m good with it.

I do find it weird, however, that I NEVER saw the “Triangle/Exclamation” alert stating no networks detected, nor did I see voicemails come in without the call being logged in “missed calls” prior to April of this year. The only thing that changed on my end between March and April is the RW App update. I’ve been using the RW service since the Beta/Defy XT days and have no complaints about the service vs cost.

Again, no pressure from me on this, just hoping that the issue will at some point be identified and resolved. I have many friends and acquaintances that have been using Android devices on other services for years and am not aware of any of them having this issue.

Thanks again for weighing in, all’s well that ends well, right?

Best regards!


Maybe not for you, which would indicate that something may have changed with your network, your cellular coverage, your model phone or something else. It WAS happening before then or @billg travelled through time to create the tip & trick on fixing it. If he has a time machine, I hope he’ll share, but I’m betting on the issue having existed in 2018 when the tip was created.


@rick.d does have a point here, though:

We did have an update that changed how we present different network states on the phone, and that exclamation point brought a lot of questions before another update toned down the message.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer