Which phones are compatible with ibotta app?

I would like to download ibotta, but it’s not compatible with my Moto G first gen. I have been thinking of purchase a new phone. Anyone know which are compatible with the ibotta app? Thanks!

What message are you getting regarding your G1? Is it related to the camera or something else?

when I go to download (on googleplay or itbotta site) the link won’t come up; instead there’s a message “this app is not compatible with your device.”

That indicates to me that your phone is still running Android 4.4.4 Ibotta requires Android 5.0 or later. Your phone, if it has the space available, can be upgraded to Android 5.1, making it compatible, by following the directions here: How to Install the 5.1 System Update for Android 4.4.4 KitKat Phones – Republic Help

1 Like

Thanks I will give it a try:)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer