Why does Galaxy S7 download update that I had postponed?


#1

I have a relatively new Galaxy S7. I haven’t powered it off in a while, but did power down (instead of just restarting a bit ago.

It took over 5 minutes before it got off of the fade in and out Samsung screen. I had no idea what was going on and thought my phone was malfunctioning. I even tried to power it off and couldn’t, but that could be the result of difficulty with the power button because of the Otter Box Case.

When it finally came back up and I entered my screen pattern to unlock it, I think it said that it was “starting Android” (can’t see that screen anymore.)

That took many minutes as well until it got back to my lock screen again, where there was a message telling me that my device had been restarted and I needed to use my pattern unlock.

Then, there was a screen (that has now disappeared) indicating that a software update (the one I had chosen to postpone a day or so ago?) had downloaded.

Now, I see why everything was taking so long, but why did (what I believe to be a Samsung update) download even though I had chosen to postpone it (and certainly wouldn’t have done so with less than a 30% charge, without being connected to a charger)?

When I go to my device “Settings” it still shows the Software Update notice at the top, telling me to tap to update the firmware.

Is all this normal behavior when powering off and back on, when a Samsung update is available, but has been postponed by the user?


#2

The phone will only postpone as long as it’s still turned on. Once you turned it off, there was nothing to prevent it from doing the install.

The first reboot after the update is completed it’s install is rather slow. All subsequent restarts or start ups should go quicker.

How is the phone working since the update?


#3

As far as I know, the phone is working fine. But, I honestly don’t know what to look for other than being able to power off and back on or restart, without problems.

I am curious about any settings that might change with an update. I had previously gone through each application and turned off mobile background data usage for most of them. However, I only see very few apps with mobile background data usage disabled now.


#4

That’s good! As long as the phone is functioning as you’re accustomed to, that’s good.

Sometimes after apps update they will automatically turn background data back on. This is their default setting. You need to turn them off manually again. Other than that with a system update, you may see slight changes in the Settings menu options. You shouldn’t see any major changes. This last update was a security patch with a few subtle changes.


#5

Thanks for your explanation/reassurance that what I was experiencing was to be expected, under the circumstances. I don’t remember my Nexus 5 ever behaving that way (forced download) when I had postponed an update to make sure that there were not major issues first. I much prefer to wait a bit for others to be the guinea pig.

I noticed that in the “Announcements” section there have been notices about various System Updates but this Samsung Galaxy S7 update (with the July 1, 2017 security patch) is not there. Do the updates for the Galaxy S7 (for unlocked phones obtained through Republic Wireless) get their updates directly from Samsung, or Republic Wireless?


#6

They come directly from Samsung. They are pre-tested by Samsung. I usually get the updates for my S7 Edge days before RW makes the announcements. So far I’ve received several without issues. Although I did have an issues when updating to Nougat. I forgot to take my SD card out before installing, and it got corrupted. My phone got a little too hot installing, this corrupted the SD card. I now use a high heat rated SD card. Haven’t had a problem since.


#7

I do recall (about a month ago) when I first got the phone that the phone got hot enough, when going through multiple passes of upgrades, that I was very concerned. I’m glad it was not just me. :slight_smile:

Thanks for the tip about the SD card. If I add one to my phone, I will keep that in mind.


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.