Why is my older Moto X not compatible with my bank app?

Where is my Moto X ?

found it but why do my primary bank app not compatible. All my other phones are

Your bank app isn’t compatible because your Moto X2 or X2 is running Android 5.1, a very old version of Android that many banks or financial apps no longer support.

1 Like

thank you My PRIMARY bank is the only one out of 7 that has done this. I told them that I will just start depositing my checks elsewhere. I guess they are just to big to care. Thank you for your excelent explaination and response, David

2 Likes

I would expect, that over time, you’ll see more of the banks move to the list of no longer supported. They do this for security reasons.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer