WIfes new E4 sim card error

What phone do you have? E4
What plan are you on? My Choice + 1 GB
Does your plan include data, or just talk & text? data, talk ,text


Hey Guys, We received the new phone last week & it was fine until today. Wife came home and it said “sim card error”, so I tried safe mode and re-seating the card now it says “cellular network not available for voice calls”. I already opened a help ticket but was wondering if anybody has a idea of what else to try.

Have you tried VOIPing the phone dial *#*#VOIP#*#*, or *#*#8647#*#*

Hi @eekzues,

This may be the result of needed updates to the operating system on your wife’s E4. Please try the following:

  1. Open Settings.
  2. Scroll to, then tap About phone.
  3. Tap System updates.
  4. Accept any updates offered.

You’ll likely need to repeat the above at least twice as it may take multiple sequential updates to fix this. Once no more updates are offered to you, please restart the phone to see if service is restored.

Republic’s word here: No Service and Republic Wireless App Asks to “Buy a SIM Card” on Moto E4 – Republic Help.

3 Likes

Thanks Guys, Andreas suggested the system updated and that worked. I initially saw a security update but didn’t think anything about it. Turns out there was a bunch of them. Grrr Folks wonder why I wont let go of my wonderful little Defy that simply works lol

3 Likes

@eekzues!

Still rock’in the 'ol Defy XT!. :grinning: Good to hear from you again. :sunglasses:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer