Wifi calling not working   1.     RestartRestart your phone by turning it off and then back on again. 2.     Reset Republic Credentials (Note: Your phone must be connected to WiFi to completI can not make calls from Wi-FI after following the suggested procedure.

Wifi calling not working

***I followed the following steps. My results are in red. ***

  1. RestartRestart your phone by turning it off and then back on again.

  2. Reset Republic Credentials
    (**Note:**Your phone must be connected to WiFi to complete this step. For a video of this step, please see How to VOIP Your Phone )

  3. Open the dialer, then dial ##8647##

  4. The dialer will clear, and the Republic arc notification icon will reappear after about a minute. (If the arc notification icon does not reappear, restart your phone. The arc should then appear after your phone restarts.)

  5. **Update the PRL (Preferred Roaming List)**Perform a PRL update by following the instructions here: Update the PRL.
    This step was not completed and I received the following code: Comms_socket_error

  6. Wipe Sprint SettingsWhen the PRL update is complete, open the dialer and dial **##72786#. **An SCRTN screen will display. Tap Yesto continue (you won’t lose any data). Your phone will restart and go through cellular activation, then restart again.
    Note: Once this step is complete you must complete Step 5 or your phone will not work over Cellular.

  7. Update the ProfileThis will restore or refresh your phone’s Sprint settings; go to Settings > System Update > Update Profile.
    This step was not completed and I received the following code: Comms_socket_error

  8. **Note:**You’ll need to be connected to WiFi in order to update the Profile.

  9. Restart AgainThe phone should automatically restart after a few seconds. If it doesn’t, then manually restart your phone.

This time, please key in the symbols as well. These steps won’t work without them. If the initial troubleshooting steps don’t work, please let us know if you’ve tried making WiFi calls on more than one WiFi network. If not, please try that and advise as to whether you get different results.

I was not able to complete this update. The Cellular activating is retrying for 5 times.

This step was not completed and I received the following code: Comms_socket_error
this error is that your phone could not get a data connection to Sprint servers (are you sure the WiFi your on is connected to the internet ?)

The ‘Comms_socket_error’ message means that your phone can’t connect to a tower. If you search for that you will find quite a few hits on discussions about it. Here is one:

Comms_Socket_Error Cellular Activation Moto X Problem Issue

In that case there was a signal but a stronger one worked when the existing signal didn’t. If that doesn’t help try searching on the error message or post again for other help/ideas.

‘Comms_socket_error’ means the phone is unable to reach Sprint’s servers. Typically the issue is caused by a WiFI connection that is blocking connectivity to Sprint. The best way to fix this is to turn the router and the phone off. Then turn on the router and a few minutes later the phone and then try again. Make sure you have Internet on the phone over the WiFi. If that does not work, try going to a hot-spot at a Cafe.

RESPONDING TO WI_FI CALLING NOT WORKING: I have tried again, I get the Comms_socket_error after the PRL updating attempt. I am on the same wi_fi connection as the phone (as i use my computer to communicate now), so it is connected to the internet. The phone shows internet connection at the top.

I attempted to do this on another connection and received the same code.

Nothing changes if I go to a cafe ( or another internet connection). I can not receive calls on Wi-Fi or cellular. I can not receive or send texts. I have repeated the process over and over. The phone continues to run and rerun 5 tries of “Cellular Activating”. Rebooting does not change this activating mode. Please help me get this completed. I can do a total reboot . Can you direct me in this effort?

Still retrying and not updating.

i tried another internet service and was still unable to update.

I tried both suggestions and the result is the same.

Please check my account to see if I have service. Republic wireless app is not activated. and is unable to determine the status of my phone.

Message an
Expert customer