Wifi calling not working for me


#1

As of 2 weeks ago I can’t make calls from England to US using WiFi. I am on the my choice text and talk plan


#2

Please see here for self-help instructions

If that doesn’t work, please submit a help ticket
https://republicwireless.com/account/tickets/


#3

Hi @dianer.hllu3f,

Some additional infomration may help us better help you. Is the experience with not being able to make WiFi calls limited to a specific WiFi network or is it all WiFi networks? Are any of the WiFi networks involved networks you or someone else available to you would have control of (access to the router)?

Beyond that, might you be able to further describe “can’t make calls”? For example, do you receive an error message? Does your phone appear to be trying to connect to local cellular networks? If so, you might try placing the phone in Airplane mode, then reenabling WiFi to see if that will allow WiFi calls.


#4

which phone?
have you swapped out the Republic SIM for a local one ? (republic SIM needs to be installed for the WiFi calling to work)


#5

The wifi is at my home and I have had no problems with it before. I get these two alerts, I have pressed ok on each my phone reboots but I still can’t make calls after the reboot.


#6

I have not changed the sim


#7

Hi @dianer.hllu3f,

Thanks for the additional context! For some reason, your phone wants to configure itself for use with Sprint’s cellular network. Obviously, even if successful, that isn’t going to help in the U.K.

In the hopes of solving this simply, have you attempted placing the phone in Airplane mode, then manually reenabling WiFi? I ask because doing so would disable the cellular radio and, hopefully, stop the nag to configure the phone for Sprint’s (non-existent in the U.K.) network. In case it helps here’s how:

  1. Swipe down twice from the top of your phone.
  2. Tap Airplane mode.
  3. Tap Wi-Fi.
  4. Sign into your Wi-Fi network if required.

Does this help?


#8

I’ve done as you suggested using airplane mode, connecting to our home wifi and still get the same messages when trying to dial a US phone.


#9

Ugh! Your phone wants to configure itself for a cellular network. The SIM in your phone is provisioned for cellular service with Sprint. Sprint’s network is CDMA. Unless you want them, I’ll spare you the details on CDMA. What I will say is unlike the U.S. there are no CDMA cellular networks in the U.K. U.K. cellular networks use a different technology (GSM), which is why I believe the attempt for configuring to a cellular network is effectively looping. I had hoped disabling the cellular radio (airplane mode) would stop that.

Here’s a shot in the dark that may or may not help. When presented with the first message (which comes from the Republic Wireless app), since it’s the only option tap OK. If I’m understanding correctly that brings you to the second message (which comes from the background app “SprintDM”. Tap Cancel on that one. Tap the square lower right to bring up a list of recently used apps. Tap the X in the upper right of SprintDM, so that it’s dismissed from memory.

With all that done and before attempting another phone call, please try a VoIP reset as described by Republic here: How to VOIP Your Phone – Republic Help. Ignore the references to Lollipop 5.1 as the process for newer phones hasn’t changed. Finally, restart your phone.

Any luck?

Additionally, you reference dialing U.S. numbers. Republic phones only make outbound calls to U.S. and Canadian numbers. You are unable to make local calls in the U.K. with the Republic SIM resident in the phone, correct? I just want to be certain your phone isn’t doing anything else strange.

You also reference your home in the U.K., so would it be accurate to say you split time between the U.S. and the U.K? Depending on your U.S. location, it might make sense to switch the cellular network provisioning on the phone from Sprint to Republic’s GSM network partner. A zip code where the phone is used in the U.S. would help us to determine if this might be a valid path forward.


Calling From Mexico
#10

I tried reset my phone as you suggested , no change after re activation.
I live in UK now but return to the US for 4 months in the summer and use my republic wireless Moto G 4 Plus phone to make calls/text when I am there. I only use it to make wifi calls to the US when I’m in here in UK not to make UK calls. I can’t understand where this Sprint network came from. I have not downloaded anything dealing with Sprint. Zip code in US is 68527


#11

Hi @dianer.hllu3f,

Somehow the phone has gotten into a state of needing to touch base with the cellular activation servers. Without access to a Sprint cell signal, there will be no way around this issue.

When you head back to the UK in the fall, put the phone in airplane mode with Wi-Fi enabled. Doing so will allow you to use the phone over Wi-Fi without allowing the phone to go into this state.

As you have several months before you are due to return to the US, would it be at all practical for you to ship the phone home to have someone complete the cellular activation steps it is requiring, then return it to you?

I don’t see that you have opened a ticket on this matter. While there’s nothing further that our technicians would be able to do to solve the state that the phone is in, we may be able to help with some other options through a support ticket. Would you like me to open a ticket on your behalf so we could explore some more creative possibilities?


#12

yes please, open a support ticket for me. Thank you. I still do not understand how Sprint took over my phone. I have never used them and this has just happened in the past 3 weeks. I have been in the UK since Sept 2017.


#13

Republic is a MVNO which contact out to the one of the major US carriers for tower acess, (republic uses 2 of these carriers (one CDMA and one GSM) and the one that your phone used is Sprint Republic the CDMA network partner)


#14

I understand your confusion! Sprint didn’t take over your phone. Sprint is once of our cellular carrier partners. In order for your phone to work when you are away from Wi-Fi (in the US) it relies on Sprint’s network. When you left the US without going into Airplane mode, it kept looking for cell signal, and thinks it should at least be roaming. It is desperately trying to do what it is supposed to do - be a phone - and needs a cellular signal to do so.


#15

Anytime the the phone was powered off and on again the airplane mode would be null unless re-enabled. Doesn’t seem like a realistic way to prevent these issues while out of the US.

rolandh’s suggestion sounds plausible. Has RW done testing to see if this would be a viable option for those temporarily leaving the US?

Is there any chance that the phone would partially activate and begin working again on WiFi if RW were to ship a GSM SIM card to dianer.hllu3f. If it’s never been tried it may be worth a shot, would be less expense and hassle that shipping a phone back and worth.

:flight_departure:


#16

My phone was in airplane mode when I flew back and was working fine to make calls over wifi from UK To US until a few weeks ago.


#17

Hi @PlaneTherapist,

Does your phone disable Airplane mode on reboot? Mine does not. This could vary by phone model.

We do not do overseas testing. I’ve asked the technicians and a GSM-outfitted phone, while less likely to do so, could get into a similar state of being unable to call, though it would not present the same error screens.

No.


#18

I don’t understand why it was working to make wifi calls from Sept 2017 until Jan 2018 and then just stopped working.


#19

I think if I am reading correctly, Sprint is upgrading their network at this time. maybe after they get done it will start working for you…
unless Sprint requires a refresh on everyone’s phone after the upgrade…


#20

Good afternoon southpaw,

Just checked and my G4 doesn’t. I’d wrongly assumed it would rest to a normal condition sort of like it re-enabling WiFi. Likely no difference with other devices. Android wouldn’t want to be responsible for an airplane cratering in if a device rebooted on it’s own. Thanks.

:flight_departure: