Wifi Calls Going Straight to Voicemail

Moto G3, owned 1 year approximately I use airplane mode and use wifi for calling. After your update for the Moto4G I am assuming. My phone about 3 days ago shut down at night. I use it for an alarm clock so (my wifi is on in my home, My airplane mode is on so I will not use my little ole gigabyte plan. Yes the republic arch is on and airplane too. Yes the battery was at 84%. I thought that odd but I am able to turn the phone back on slip it into the case (didn’t notice what it said at start up) Now you can call me in airplane mode with republic wifi arch on and it goes straight to voice mail. I can dial out on the phone, text, surf the web or do everything except get a call. I checked the settings all is good. Could have I gotten an update via internet at night? I would have said it was the other persons phone however Tracfone and T-Mobile are not having issues. Just republic or maybe when my phone shut down all by itself. It is odd, I can get some calls now! I am using 2 different wifi systems Home Verizon, Work Xfinity. I guess it’s time to update my dinosaur phone. Any Views?

Hi @anitaw,

I’m sorry to see that your question has gone unanswered for so long, and I don’t see a support ticket about this matter from you.

None of our updates intended for the G4 would affect your phone.

If your inbound Wi-Fi calls are still going straight to voicemail when then phone is in airplane mode, some typical causes are an app conflict, or a change to your Wi-Fi network.

Here are some things to try:

  • Put the phone in Safe Mode and then see if inbound Wi-Fi calls (in Airplane mode with Wi-Fi enabled) still go straight to voicemail.
  • Reboot your router and test.
  • Test on a different Wi-Fi network, like a nearby McDonald’s

Please let us know if the problem persists.

If you are on WiFi, you should really not use a meaningful amount of cell, I would take the phone out of airplane mode, it defeats all of our hybrid goodness to remove cell from the equation. On GSM it does not save battery, appreciably, to turn off cell and there are other ways to turn off cell, than doing airplane mode. Have you tried turning off cell data in our app? See if that helps, it will make it so we still have access to data for hybrid stuff but no apps will have access to data.

Message an
Expert customer