Wifi connect failure

What phone do you have?

What plan are you on?

Does your plan include data, or just talk & text?


Issue Description

Moto X
No Data

Hi @stevem.ylmquy - and welcome back to the Community. That’s not a lot of information to troubleshoot with but let’s give it a go. First thing I would do is restart all the equipment; Modem, Router, and Cell phone. This assumes you’re experiencing this on your home WiFi.

You can always come back with more details, such as the actual failure message and where this is happening, if the restarts of all the equipment does not help.

6 Likes

@stevem.ylmquy

Along with what @freddyp asked:

Are you getting an Authentication error?

If you toggle Bluetooth does it stay on or turn itself off? If Bluetooth cannot stay on and WiFi cannot stay on, this indicates a hardware failure. Bluetooth and WiFi are on the same chip.

So a few specifics as to what’s going on would help.

1 Like

Yes Authentication error, Bluetooth stay on. Ever once in a while it will connect to WiFi but then disconnects by itself. I tried to reset phone, reset WiFi. same problem. Does it with all Wifi hot spots. Seems like a hardware problem?

@stevem.ylmquy Doesn’t sound like a hardware problem, but does sound like it needs it’s a clear out!

You have Moto X, I’m going to guess it’s either 1st or 2nd gen? If it is, clear Android System Cache:

This will take about 20 minutes and will not delete personal information. What it will do is give Android wiggle room for it’s daily operations.

When this is completed, see if it will hold onto the WiFi connection. If not, forget the network and try to connect again. Entering your password carefully.

This is most likely an issue with one of your downloaded apps. I recommend restarting in safe mode.

If the WiFi remains stable in Safe Mode…then you will need to go through your downloaded apps one by one and delete them to figure out the culprit. When I had this issue with my Moto X several years ago it was caused by the Dunkin Donut app. Removing the app fixed the issue for me.

Yes it worked in safe mode. Switched back and still connects now. Your probably right about it being an app. I will delete all the ones I don’t use. Thanks for your help.

2 Likes
Message an
Expert customer