WIFI connected but no Internet

What phone do you have? **Moto G5 Plus (64GB)

What plan are you on? My Choice + 1 GB

Does your plan include data, or just talk & text? Talk + text

Issue Description

Recently I am finding that after being out of range of my home WIFI network when I return it connects to WIFI but there is no internet connection. If I notice it, I can turn of WIFI and turn in back on it will connect to both WIFI and internet. But sometimes it will take several attempts, repeating the process, before it works. The problem is that I may not notice it for some time which means I drive up my cell traffic instead of using free WIFI data. I have had this plan for quite some time, but I am concerned that I will soon be driving my costs up unnecessarily.

Is it possible that your phone is connecting to another network of similar strength as your home network that is saved to your phone but you don’t have access to it…common culprits are “xfinity wifi” and “Cable wifi”…they are common hotspots… that once you connect to them at some point in time…your phone will auto-connect to them in the future…however if you are not an existing xfinity member you won’t have access to the internet through that hotspot.

1 Like

I do not think that is happening here, as I am in a out-of-the-way location and see only a couple of neighbors within WIFI range. I do not see any names like that in the list of hotspots on my phone either and the name of the network I see on my phone is the name I have assigned in my router. Just to make sure, I changed the name of my home network to see if there was another with the same name masquerading as my network, and then connected my phone to that new node. I will watch to see if it makes any difference.

1 Like

What are you using as an indicator for connection to the internet?

The pie slice icon on the top has an additional symbol on it and when I look at the details on settings > Network > WIFI it says “no internet”. I also noticed that my cell usage is about a factor of 10 higher than normal, and my travel and phone usage pattern is not otherwise any different than usual.

Do you have any Antivirus or similar app on your phone?

Also take a look at this one

I have been doing some digging after your comments, and observing the behavior on my phone in the mean time. In addition I have continued to watch closely to monitor my phone and internet status to see what is going on. I still do not see any other web sites that have no internet access when I am home. In responding to your question about how do I know the status, I was looking through the documentation for my phone (Moto G5 plus) and did not find it but found this statement on p. 48 - “If a router previously did not have an internet connection your phone will not automatically connect to it.” The problem occurred again today, after I had driven with my GM vehicle which comes by default with OnStar. After my initial free period I found it quite unnecessary and cancelled it so I do not have any WiFi service, but the access point remains active anyway (and GM can snoop at my vehicle)! So I think it is very likely that this is the source of my problem. The connection disappears when the vehicle is parked in the garage, so I do not see that it has been connected - in fact I deleted this from my list of “Saved Networks” as well and it is not in the list. But when I start the vehicle it pops into the list and must connect even though it is locked. I will test this theory again tomorrow when I drive with this vehicle out of range from my home WiFI router to confirm if that is the case. Then I will have to figure out how to get my phone to TOTALLY forget about this network or find the OnStar box in my vehicle and disconnect it. Not sure why it started to misbehave now, as it has been this way for at least 3 years and now it is a problem.

That is indeed an interesting line of inquiry…do let us know how it pans out. On the face of it…is seems not very plausible that a phone should connect to a WiFi network that has been manually removed from Saved Networks… but it will be interest to see how this pans out for you.

The other thing to look at is your per app data usage…which you can observe in the RW app. RW also gives you data usage on a per day basis…so you can try to correlate that to when you were in the house and if that’s when all this data was getting used on your phone. Also, you may want to look at the Android Mobile Data usage to see if the app data usage was Foreground or Background…as that might provide some additional insight as to when this data usage is occuring.

You might start afresh by using the Android WiFi Reset function, this will remove all Wi-Fi, Mobile data & Bluetooth network settings.
This can be found in

  • Android Settings/System/Advanced/Reset options/Reset Wi-Fi, mobile & Bluetooth (or search in settings for it)
    • You will need to re-authenticate to your WiFi, and it will take a power off/on cycle to re-establish connection
1 Like

I have additional occasions when the phone does not connect to my home WiFi internet, again after driving my GM vehicle. I have set the phone in my dash holder as I drive back home and watch as it detects (but does not connect to) the other WiFi nodes along the way. The one that stays in the list is always my onboard OnStart node. It does not connect to it, or any of the other nodes that appear. I did a reset from the WiFi settings page and will try again this afternoon to see if there is any change.

1 Like

Hi @dh2a,

Have you rebooted your home Wi-Fi network recently?

1 Like

@dh2a Are you still having this issue?

Yes, perhaps 1 out of 2 times I leave home and return the phone does not re-connect to the internet via my home WiFi. I had thought it might have something to do with my GM vehicle but it has occurred with our other car as well. I can sometimes turn of WiFi and when I reconnect it has internet connectivity. Sometimes it takes multiple disconnect/reconnect sequences, and on occasion it will not reconnect until I leave WiFi off for an hour of so. So I have to be careful whenever I come home to check the status to avoid using up my cell data quota. My wife has a Republic phone as well and has never had the problem.

Have you taken the simple step of powering off the wifi router for about 10 seconds and powering it back on. Although other devices are working sometimes bad information about a specific device can get cached in the router and resetting it via a power cycle can fix strange connections issues such as this one.

Yes, I did that (again today) - powered it off
and then back on after waiting a few minutes. My phone
connected to the router, but no internet. Switched to another
node on the router and it connected with internet. (This
Netgear router has two nodes, operating at different

The couple of things that I see we have all neglected to consider … the possibility that a 3rd party app is interfering with then normal Android WiFi operation or the operation of the RW App in ‘Handover to WiFi function’ is contributing to the problem.
If you could try the following, make change and run for a period of time to test, if failure continues, then try next step:

  1. In the RW App/ :settingsicon: Settings / Advanced Settings ’ :solved: Enable / Handover to WiFi when appropriate
  2. Boot up in Safe Mode
1 Like

Perhaps the connection with no Internet was your 5GHz band and when you switched to the other one it connected to 2.4GHz

  • Normally when users have separated the bands, they have provided a naming convention like, ‘My wonderful ISP - 2.4GHz’ or ‘My wonderful ISP - 5GHz’
    • WiFi devices are notorious for hanging on to a signal, even when it becomes dysfunctional. Band Steering was developed to auto switch to the best available, but the effectiveness of that is still questionable.
  • I would suggest making sure your router is at the latest available code level

I tried this sequence yesterday but didn’t get it quite right. First, the Handover to WiFi was already checked do did not change it. I didn’t get the right Safe Mode instructions so that did not work. Had the ‘No Internet’ problem again when I returned to my home WiFi. Today I got the Safe Mode instructions for my phone (Moto G5+) and after the reboot the router connected, but no internet again.

Message an
Expert customer