WIFI connected but no Internet

I have been doing some digging after your comments, and observing the behavior on my phone in the mean time. In addition I have continued to watch closely to monitor my phone and internet status to see what is going on. I still do not see any other web sites that have no internet access when I am home. In responding to your question about how do I know the status, I was looking through the documentation for my phone (Moto G5 plus) and did not find it but found this statement on p. 48 - “If a router previously did not have an internet connection your phone will not automatically connect to it.” The problem occurred again today, after I had driven with my GM vehicle which comes by default with OnStar. After my initial free period I found it quite unnecessary and cancelled it so I do not have any WiFi service, but the access point remains active anyway (and GM can snoop at my vehicle)! So I think it is very likely that this is the source of my problem. The connection disappears when the vehicle is parked in the garage, so I do not see that it has been connected - in fact I deleted this from my list of “Saved Networks” as well and it is not in the list. But when I start the vehicle it pops into the list and must connect even though it is locked. I will test this theory again tomorrow when I drive with this vehicle out of range from my home WiFI router to confirm if that is the case. Then I will have to figure out how to get my phone to TOTALLY forget about this network or find the OnStar box in my vehicle and disconnect it. Not sure why it started to misbehave now, as it has been this way for at least 3 years and now it is a problem.

That is indeed an interesting line of inquiry…do let us know how it pans out. On the face of it…is seems not very plausible that a phone should connect to a WiFi network that has been manually removed from Saved Networks… but it will be interest to see how this pans out for you.

The other thing to look at is your per app data usage…which you can observe in the RW app. RW also gives you data usage on a per day basis…so you can try to correlate that to when you were in the house and if that’s when all this data was getting used on your phone. Also, you may want to look at the Android Mobile Data usage to see if the app data usage was Foreground or Background…as that might provide some additional insight as to when this data usage is occuring.

You might start afresh by using the Android WiFi Reset function, this will remove all Wi-Fi, Mobile data & Bluetooth network settings.
This can be found in

  • Android Settings/System/Advanced/Reset options/Reset Wi-Fi, mobile & Bluetooth (or search in settings for it)
    • You will need to re-authenticate to your WiFi, and it will take a power off/on cycle to re-establish connection
1 Like

I have additional occasions when the phone does not connect to my home WiFi internet, again after driving my GM vehicle. I have set the phone in my dash holder as I drive back home and watch as it detects (but does not connect to) the other WiFi nodes along the way. The one that stays in the list is always my onboard OnStart node. It does not connect to it, or any of the other nodes that appear. I did a reset from the WiFi settings page and will try again this afternoon to see if there is any change.

1 Like

Hi @dh2a,

Have you rebooted your home Wi-Fi network recently?

1 Like

@dh2a Are you still having this issue?

Yes, perhaps 1 out of 2 times I leave home and return the phone does not re-connect to the internet via my home WiFi. I had thought it might have something to do with my GM vehicle but it has occurred with our other car as well. I can sometimes turn of WiFi and when I reconnect it has internet connectivity. Sometimes it takes multiple disconnect/reconnect sequences, and on occasion it will not reconnect until I leave WiFi off for an hour of so. So I have to be careful whenever I come home to check the status to avoid using up my cell data quota. My wife has a Republic phone as well and has never had the problem.

Have you taken the simple step of powering off the wifi router for about 10 seconds and powering it back on. Although other devices are working sometimes bad information about a specific device can get cached in the router and resetting it via a power cycle can fix strange connections issues such as this one.

Yes, I did that (again today) - powered it off
and then back on after waiting a few minutes. My phone
connected to the router, but no internet. Switched to another
node on the router and it connected with internet. (This
Netgear router has two nodes, operating at different
frequencies.)

The couple of things that I see we have all neglected to consider … the possibility that a 3rd party app is interfering with then normal Android WiFi operation or the operation of the RW App in ‘Handover to WiFi function’ is contributing to the problem.
If you could try the following, make change and run for a period of time to test, if failure continues, then try next step:

  1. In the RW App/ :settingsicon: Settings / Advanced Settings ’ :solved: Enable / Handover to WiFi when appropriate
  2. Boot up in Safe Mode
1 Like

Perhaps the connection with no Internet was your 5GHz band and when you switched to the other one it connected to 2.4GHz

  • Normally when users have separated the bands, they have provided a naming convention like, ‘My wonderful ISP - 2.4GHz’ or ‘My wonderful ISP - 5GHz’
    • WiFi devices are notorious for hanging on to a signal, even when it becomes dysfunctional. Band Steering was developed to auto switch to the best available, but the effectiveness of that is still questionable.
  • I would suggest making sure your router is at the latest available code level

I tried this sequence yesterday but didn’t get it quite right. First, the Handover to WiFi was already checked do did not change it. I didn’t get the right Safe Mode instructions so that did not work. Had the ‘No Internet’ problem again when I returned to my home WiFi. Today I got the Safe Mode instructions for my phone (Moto G5+) and after the reboot the router connected, but no internet again.

It may or not be related, but I had a strange issue this morning when I unplugged my phone I noticed I had no cell connection and when I went to ‘Mobile Network’ all the options were greyed out and would not allow me to change them. When I went to the Republic app it told me to install my SIM!! I powered it down and back up again and it took me to a screen that said my number was not established, and to reboot.
When I rebooted my cell network had returned to normal. WiFi was connected with no internet and I am finding that if I switch back and forth between the two nodes about 5-6 times I it get connected. So perhaps I have bigger problems ahead. I was not ready for another phone by a long ways. :frowning:

How did the Safe Mode instruction you’got’ differ from those that Republic Help published … so that information can be passed back to them for possible correction of the Help doc.

The help doc from Republic was very clear and that is what I used today and it worked precisely as it was described. I do not recall how I found safe mode yesterday, probably just from searching from my desktop - and as is the usual case, everyone one on the web has their own flavor of help (often misguided) and I didn’t take the time to do proper diligence.

The term Safe Mode in the Republic Wireless user forum is one of the many ‘keywords’ that are auto linked to the appropriate Safe Mode – Republic Help document. This was provided by Republic’s folks (through the efforts of @southpaw) to easily refer folks to the appropriate doc without introducing the usual copy/paste & typo that would otherwise occur.

I am still having this problem, perhaps 1 out of 3 times I return home after being away for a time. I thought it might be related to my driving a vehicle with an ‘inactive’ OnStar subscription, but it happens when I leave with another vehicle. I thought it might be related to when I use a fitness tracker with a BlueTooth connection to my phone, but it occurs even when I have not used it. The phone has a BlueTooth connection to a smart watch, but that I have connected all the time. I have verified that my router is at the most current level and have rebooted it numerous times but still have the occurrences when I return I have no internet. I do not seem to have any issues when I am away and the phone connects to Guest networks with no problems. My wife also has a Republic Wireless phone but has not seen this problem. And I have used this phone and router for over a year before the problem started occurring. So I agree, some application or some upgrade has introduced the problem. So what do I do now? Neither replacing the phone or the router is a guaranteed fix. It is a very irritating issue that I may reluctantly have to live with. :frowning:

Message an
Expert customer